[linux-dvb] airstar2 /dev/dvb disappears

Christian Schmitt chrschmitt at gmail.com
Mon Apr 11 22:49:44 CEST 2005


Hi all,

I'm using DVB-T for quite a while now with a Airstar2 card.
lspci:
Techsan Electronics Co Ltd B2C2 FlexCopII DVBchip / Technisat SkyStar2
DVB card (rev 02)
I always used the skystar2 driver until I found out recently that it
is obsoleted and I should use the b2c2_flexcop now. Well, I switched
over and noticed that switching from one channel to an other is much
faster now and the driver is much more stable. I want to express my
gratitude for the great work.
However I still have one major issue: The correspondig entrys in the
/dev/dvb directory disappear from time to time and it is rather tricky
to get them back :-)
I use udev and when I boot my computer, the driver gets loaded by
hotplug/coldplug. But It happens more often than not, that I get no
dvb entry in /dev which makes my card unusable. I was not able to find
out when exactly this problem occurs, but it's hard work to get the
entry back. I have to reboot my machine several times and if I am
lucky, the entry appears again after several reboots. Then I can start
kaffeine or xine and watch TV for hours without any problem, but when
I stop watching TV and close the program, the /dev/dvb directory might
disappear again after some time. I had this problem already with the
skystar2 driver, but it also occurs with the flexcop driver as well.
I hope to get some help to eliminate this last major issue.

Best regards

Chris




More information about the linux-dvb mailing list