[linux-dvb] TwinhanDTV alpha

Patrick Boettcher patrick.boettcher at desy.de
Thu Aug 25 14:28:12 CEST 2005


On Thu, 25 Aug 2005, Martin Ereth wrote:

> I bought the TwinahnDTV alpha USB device some days ago.
>
> So I downloaded linuxtv-dvb-1.1.1.tar.bz2.
> The installation (make , ./insmod in build-2.6)aborted: dvb_net.c:81: union 
> has no member named ethernet. The kernel was 2.6.12.2. I also tried it with 
> kernel 2.6.12.5. Same error.
>
> So I tried dvb-kernel from cvs. A error occurs in dvb_frontend.c.
> I found the following two sites:
> -http://linuxtv.org/wiki/index.php/Supported_DVB_cards
> -http://linuxtv.org/wiki/index.php/DVB_USB#Twinhan_DVB-T_USB2.0
>
> The second says: Twinhan alpha is supported. No problem.
> The first one says: I don't know what Twinhan alpha is.

The second one is right. The Supported_DVB_cards is out of date.

> So I ask myself: Am I so stupid and bought a unsupported device?

No.

> Can anyone tell me the truth?
Yes.

> Has anyone this DVBT-Stick running?
Yes.

> Can anyone give me a trick?
Yes.

vp7045 is the driver for the twinhan alpha. It will be included in kernel 
2.6.13, so you could try 2.6.13-rc7, which should be quite stable.

Or you patch your 2.6.12 kernel with patches from here: 
http://www.linuxtv.org/downloads/patches/

Or you use dvb-kernel CVS and check out the revisions from 2005-06-30 of 
the files which don't compile.

HTH
Patrick.

--
   Mail: patrick.boettcher at desy.de
   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/




More information about the linux-dvb mailing list