[linux-dvb] Pinnacle PCTV 300i: tuner module not supported yet ?

Vesa Voutilainen wanderer at netikka.fi
Thu Aug 25 19:52:50 CEST 2005


Thank you Rainer,

about that video4linux patch, I've tried several, the latest make script has 
code in it, which won't compile saa7134-dvb module if kernel is lower than 
12.

With older patches, I had several problems. This was the first that recognized 
card correctly.

I'll look at that kernel 11 stuff again, but would really appreciate solution 
for this 12 series kernel.

From video4linux patch, 
Make.config:
/.. 
MDIR			:= v4l2
snap			:= video4linux

CONFIG_VIDEO_BTTV	:= m
CONFIG_VIDEO_SAA7134	:= m
CONFIG_VIDEO_IR		:= m
CONFIG_VIDEO_TUNER	:= m
CONFIG_VIDEO_TVAUDIO	:= m
CONFIG_VIDEO_CX88	:= m

CONFIG_VIDEO_ALSA	:= n

# doesn't build on kernels older than 2.6.12

CONFIG_VIDEO_CX88_DVB	:= n
CONFIG_VIDEO_SAA7134_DVB := n

ifneq ($(KERNELRELEASE),)
need_dvb = $(shell test $(SUBLEVEL) -ge 12 && echo yes)
endif

ifeq ($(need_dvb),yes)
 CONFIG_VIDEO_CX88_DVB	:= m
 CONFIG_VIDEO_SAA7134_DVB := m
endif

../


On Thursday 25 August 2005 19:28, Rainer Schubert wrote:
> On Thu, 25 Aug 2005, wanderer at netikka.fi wrote:
> > Hi,
>
> Hi Vesa and the list,
>
> > I've tried to get my Pinnacle card to work. This list has other messages
> > concerning this same driver and I've followed those instructions and
> > tried kernels 2.6.11 and 2.6.12 with video4linux patches. With 2.6.11 and
> > v4l patch saa7134-dvb driver isn't loaded, but with 12 it is, so I used
> > that.
>
> Up to now I have used kernels 2.6.10 and 2.6.11 on two different machines
> running Debian Linux and patches from video4linux.  Both cards are
> working.
>
> > Now the board is found correctly, but frontend won't work because mt352
> > gives trouble. Is it so that tuner module mt20xx don't support mt2050
> > tuner yet ?
> >
> > From /var/log/messages:
> > /...
> > kernel: saa7130/34: v4l2 driver version 0.2.14 loaded
> > kernel: saa7130/34: snapshot date 2005-08-01
> > kernel: ACPI: PCI interrupt 0000:00:08.0[A] -> GSI 10 (level, low) -> IRQ
> > 10 kernel: saa7133[0]: found at 0000:00:08.0, rev: 208, irq: 10, latency:
> > 32, mmio: 0xeb101000
> > kernel: saa7133[0]: subsystem: 11bd:002f, board: Pinnacle PCTV 300i DVB-T
> > + PAL [card=50,insmod option]
> > kernel: saa7133[0]: board init: gpio is 600e000
> > kernel: saa7133[0]: dsp access wait timeout [bit=WRR]
> > kernel: saa7133[0]: i2c eeprom 00: bd 11 2f 00 54 20 1c 00 43 43 a9 1c 55
> > d2 b2 92
> > kernel: saa7133[0]: i2c eeprom 10: ff e0 60 06 ff 20 ff ff 00 30 8d 2c 0f
> > 7e ff ff
> > kernel: saa7133[0]: i2c eeprom 20: 01 2c 01 03 03 01 04 31 98 ff 00 a8 ff
> > 21 00 c2
> > kernel: saa7133[0]: i2c eeprom 30: 96 10 03 32 15 20 ff ff 0c 22 17 77 03
> > 17 fd b6
> > kernel:  : chip found @ 0x96 (saa7133[0])
> > kernel: tuner 2-004b: microtune: companycode=8000 part=21 rev=06
> > kernel: tuner 2-004b: microtune unknown found, not (yet?) supported,
> > sorry
> >
> > :-/ kernel: saa7133[0]: registered device video0 [v4l2]
> >
> > kernel: saa7133[0]: registered device vbi0
> > .../
>
> Here is from my dmesg:
> Linux video capture interface: v1.00
> saa7130/34: v4l2 driver version 0.2.13 loaded
> saa7130/34: snapshot date 2005-05-25
> ACPI: PCI interrupt 0000:00:09.0[A] -> GSI 17 (level, low) -> IRQ 17
> saa7134[0]: found at 0000:00:09.0, rev: 1, irq: 17, latency: 32, mmio:
> 0xcfff7c00
> saa7134[0]: subsystem: 11bd:002d, board: Pinnacle PCTV 300i DVB-T + PAL
> [card=50,autodetected]
> saa7134[0]: board init: gpio is c806000
> saa7134[0]: i2c eeprom 00: bd 11 2d 00 f8 f8 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7134[0]: i2c eeprom 10: 00 f0 04 04 ff 20 ff ff ff ff ff ff ff ff ff ff
> saa7134[0]: i2c eeprom 20: 01 40 01 02 03 ff 03 01 08 ff 00 25 ff ff ff ff
> saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> tuner 1-0060: chip found @ 0xc0 (saa7134[0])
> tuner 1-0060: microtune: companycode=3cbf part=42 rev=2f
> tuner 1-0060: microtune MT2050 found, OK
> tda9885/6/7: chip found @ 0x86
> saa7134[0]: registered device video0 [v4l2]
> saa7134[0]: registered device vbi0
> saa7134[0]: pinnacle 300i dvb setup
> DVB: registering new adapter (saa7134[0]).
> DVB: registering frontend 0 (Zarlink MT352 DVB-T)...
>
> > And dmesg gives line:
> > /..
> > tuner 2-004b: Tuner has no way to set tv freq
> > ../
> >
> > Technical data tells that
> > video decoder is Philips SAA7134 (and board identifies as 7133, well,
> > wouldn't count very much on this info).
> > tv tuner is Microtune MT2050 frequency range 45.75 to 863.25 MHz
> > Analog demodulator TDA 9885
> > DVB-T demodulator Zarlink MT352 16,64 QAM, QPSK 6,7,8 MHz bandwith UHF
> > VHF
>
> To the best of my knowledge the above data is correct.
>
> I am just compiling kernel 2.6.12.5 on the other machine for testing.
>
> > Am I in trouble or have I simply forgotten something ?
>
> Can't say just now, maybe after testing with 2.6.12.5 ?
>
> > Vesa
>
> Regards,
> Rainer




More information about the linux-dvb mailing list