[linux-dvb] i2c problem with twinhan DST-S VP-1020/FC3?

Manu Abraham manu at kromtek.com
Thu Feb 24 15:13:35 CET 2005


Ben Jiang wrote:
> Manu Abraham wrote:
> 
>> bb wrote:
>>
>>> Hi, all,
>>>
>>> I am trying to have a VP-1020 working and I have been playing this 
>>> for a few weeks without luck.  I have 2.6.11-rc3-bk7 installed and 
>>> the lastest dvb-kernel from cvs (updated yesterday), I keep getting 
>>> error when trying to load the modules. I checked the code and I think 
>>> the problem happens inside write_dst when called from dst_check_ci. 
>>> It seems all write_dst calls would fail. I am guessing this is 
>>> actually becasue almost all i2c writes to the card failed.
>>>
>>
>> Have you configured udev under FC3 ? This was one messy problem..
> 
> 
> Thanks for replying, Manu. And yes, I think I sort of did configure 
> udev. I upgraded to udev-050-7 about 2 days ago and I now have this in 
> my 50-udev.rules:
>    KERNEL="dvb*", PROGRAM="/etc/udev/scripts/dvb.sh %k", NAME="%c".
> Before I had udev-039-8 from FC3 and I added this in 50-udev-rules 
> (which I found somewhere in a maillist):
>    KERNEL="dvb",           NAME="dvb0"
> 
> The only difference I saw after upgraded to udev-050-7 was there were no 
> more annoying "wait_for_sysfs[9425]: error: unknown bus, please report 
> to <linux-hotplug-devel at lists.sourceforge.net>" message in the 
> /var/log/messages. But the card still wouldn't work.
> 

I have a VP-1020 (DST-MOT). I will check this up. It's been some time 
that i have tried the FTA cards.
 From the logs it does look like the writes are failing. Let me try with 
my card..

Manu




More information about the linux-dvb mailing list