[linux-dvb] Confused Air2PC owner

clemens at dwf.com clemens at dwf.com
Fri Feb 25 02:13:36 CET 2005


Let me start by saying that I am confused,
and that I have yet to see any video (or hear any sound) from my Sky2PC card.

I have previously played with both a Hauppauge 250 and a pcHDTV hd2000 and
was able to see/hear video/sound  from both of them with mplayer (but I never
really got MythTV running).

So, my problems at the moment would seem to be JUST getting to understand
this DVB driver in the kernel.

Starting at the begging:  3.2GHz Pentium4, 1GB memory, lots of disk.
Air2PC video capture card, a Nvidia FV5200 video card,
and a SoundBlaster Live! 5.1 Audio Card.

That should be all that matters here.

I pulled down a 2.6.10 kernel (I will go to 2.6.11 it that will help)
I pulled down the dvb-kernel from CVS as of Monday (21Feb)
and I pulled down the dvb-apps at the same time.
built that.

I pulled down the current MythTV from CVS as of Tuesday (22Feb)

I have the
      Installng and Using MythTV
and   Fedora Myth(TV)ology
documents, and I have the

      MythTV and Air2PC ATSC card on Fedora Core 3
and   Taylor Jacob's DVB Patch Setup HOWTO
documents for the dvb driver.

That said, I can do the

        cd /usr/src/dvb-apps/util/szap/channels-conf/atsc
        perl ./make_atsc_chanconf.pl 87109 >~/.azap/channels.conf

and I get

    [root at mythtv .azap]# more /root/.azap/channels.conf
    KNME:599000000:8VSB:0:0
    KASA:551000000:8VSB:0:0
    KASY:659000000:8VSB:0:0
    KWBQ:563000000:8VSB:0:0
    KRQE:485000000:8VSB:0:0
    KOAT:515000000:8VSB:0:0
    KOB:545000000:8VSB:0:0
    KLUZ:641000000:8VSB:0:0
    KNAT:533000000:8VSB:0:0
    KNMD:189000000:8VSB:0:0
    KAZQ:491000000:8VSB:0:0
    KCHF:195000000:8VSB:0:0

The channels found, and there frequencies are correct, but I dont
know what the :8VSB:0:0 is trying to tell me.

Anyone?  Jump right in here...

All of the stations broadcast from the top of Sandia Peak, about
5 miles away and 5000 ft higher than we are here in the city, so
the signal strength is high for all of them.

Choosing just one at random, I see:

    [root at mythtv ~]# azap kob
    using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
    tuning to 545000000 Hz
    video pid 0x0000, audio pid 0x0000
    status 1f | signal fad0 | snr dbaa | ber 00007ff8 | unc 00000000 | 
FE_HAS_LOCK
    status 1f | signal fa60 | snr da90 | ber 000003e0 | unc 00000000 | 
FE_HAS_LOCK
    status 1f | signal fab0 | snr dcc4 | ber 00000898 | unc 00000000 | 
FE_HAS_LOCK
    status 1f | signal faf0 | snr dbaa | ber 00000860 | unc 00000000 | 
FE_HAS_LOCK
    status 1f | signal fab0 | snr d8ba | ber 000009b0 | unc 00000000 | 
FE_HAS_LOCK
    status 1f | signal fa20 | snr da32 | ber 000007e8 | unc 00000000 | 
FE_HAS_LOCK


If I now startup mythbackend/mythfrontend I get to the "Watch TV" message
I click on it, the screen goes black for about 15s, then Im back at the same
message.

If I kill mythfrontend at this point, and go look at the messages printed by
mythbackend, I see:

---

mythbackend --verbose channel,record
Starting up as the master server.
2005-02-24 17:47:37.333 DVB#0 DVB SI Table Parser Started
2005-02-24 17:47:37.334 DVB#0 Using DVB card 0, with frontend Nextwave nxt2002 
VSB/QAM frontend.
2005-02-24 17:47:37.334 DVB#0 Trying to tune to channel 35.
2005-02-24 17:47:37.334 DVB#0 DVB Signal Monitor Starting
2005-02-24 17:47:37.336 DVB#0 Signal Locked
2005-02-24 17:47:37.353 DVB#0 ERROR - Could not find dvb tuning parameters for 
transport 0
2005-02-24 17:47:37.354 DVB#0 ERROR - Failed to get channel options for 
channel 35.
 is defined, but isn't attached to a cardinput.
2005-02-24 17:47:37.361 mythbackend version: 0.17.20050220-1 www.mythtv.org
2005-02-24 17:47:37.361 Enabled verbose msgs : important general channel record
2005-02-24 17:47:39.359 Reschedule requested for id -1.
2005-02-24 17:47:39.365 Scheduled 0 items in 0.0 = 0.00 match + 0.00 place
2005-02-24 17:47:39.367 Seem to be woken up by USER
2005-02-24 17:49:27.868 MainServer::HandleAnnounce Playback
2005-02-24 17:49:27.868 adding: mythtv.dwf.com as a client (events: 0)
2005-02-24 17:49:27.876 Getting next free recorder after : -1
2005-02-24 17:49:27.876 Card 1 is local.
2005-02-24 17:49:27.888 MainServer::HandleAnnounce Playback
2005-02-24 17:49:27.888 adding: mythtv.dwf.com as a client (events: 1)
2005-02-24 17:49:27.897 MainServer::HandleAnnounce Playback
2005-02-24 17:49:27.898 adding: mythtv.dwf.com as a client (events: 0)
2005-02-24 17:49:27.934 MainServer::HandleAnnounce Playback
2005-02-24 17:49:27.934 adding: mythtv.dwf.com as a client (events: 0)
2005-02-24 17:49:27.941 adding: mythtv.dwf.com as a remote ringbuffer
2005-02-24 17:49:27.949 Changing from None to WatchingLiveTV
2005-02-24 17:49:27.972 Using profile 'Live TV' to record
2005-02-24 17:49:27.974 DVB#0 Recorder: Card opened successfully (using PS 
mode).
2005-02-24 17:49:27.975 DVB#0 AutoPID Complete - PAT/PMT Loaded for service
2005-02-24 17:49:27.975 DVB#0 Service is FTA
2005-02-24 17:49:27.975 DVB#0 ERROR - No PIDS set, please correct your channel 
setup.
2005-02-24 17:49:28.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:29.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:30.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:31.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:32.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:33.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:34.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:35.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:36.988 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:37.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:38.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:39.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:40.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:41.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:42.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:43.082 Couldn't read data from the capture card in 15 
seconds. Stopping.
2005-02-24 17:49:43.111 Changing from WatchingLiveTV to None
2005-02-24 17:49:43.987 DVB#0 WARNING - No data from card in 1 second.
2005-02-24 17:49:43.987 Closing DVB recorder

---
and by mythfrontend:

[root at mythtv ~]# mythfrontend --verbose playback
2005-02-24 17:48:56.673 mythfrontend version: 0.17.20050220-1 www.mythtv.org
2005-02-24 17:48:56.673 Enabled verbose msgs : important general playback
2005-02-24 17:48:57.135 Switching to square mode (G.A.N.T.)
2005-02-24 17:48:57.407 Joystick disabled.
2005-02-24 17:48:57.442 Registering Internal as a media playback plugin.
2005-02-24 17:49:27.855 Connecting to backend server: 204.134.2.12:6543 (try 1 
of 5)
2005-02-24 17:49:27.862 Using protocol version 14
2005-02-24 17:49:27.893 Using protocol version 14
2005-02-24 17:49:27.995 Disable DPMS
2005-02-24 17:49:33.088 taking too long to be allowed to read..
2005-02-24 17:49:38.084 taking too long to be allowed to read..
2005-02-24 17:49:43.081 taking too long to be allowed to read..
2005-02-24 17:49:43.081 Took more than 10 seconds to be allowed to read, 
aborting.
Couldn't read file: rbuf://204.134.2.12:6543/mnt/video/Transients/ringbuf1.nuv
2005-02-24 17:49:43.104 Changing from None to WatchingLiveTV
2005-02-24 17:49:43.104 Decoder not alive, and trying to play..
2005-02-24 17:49:44.001 Changing from None to None

---

I see the following lines which look like errors

    2005-02-24 17:47:37.353 DVB#0 ERROR - Could not find dvb tuning parameters 
for transport 0
    2005-02-24 17:47:37.354 DVB#0 ERROR - Failed to get channel options for 
channel 35.

I have no idea what that is trying to say.
Ditto the lines

    2005-02-24 17:49:27.975 DVB#0 AutoPID Complete - PAT/PMT Loaded for service
    2005-02-24 17:49:27.975 DVB#0 Service is FTA
    2005-02-24 17:49:27.975 DVB#0 ERROR - No PIDS set, please correct your 
channel setup.
    2005-02-24 17:49:28.988 DVB#0 WARNING - No data from card in 1 second.

No idea what AutoPID is trying to do, and I have no Idea what to do to respond 
to

    ERROR - No PIDS set, please correct your channel setup.

on the third line.

---

So what have I missed?
Whats my next step?

I have seen the PID thing mentioned, but with no real example of what is needed
to fix the problem.  This wasn't something I saw with the other cards and the
other drivers...

                                        Reg.Clemens
                                        clemens at dwf.com






More information about the linux-dvb mailing list