[linux-dvb] DEC2000-t help

Peter Beutner p.beutner at gmx.net
Thu Jul 7 23:22:06 CEST 2005


gneeki schrieb:
> Peter, thanks for your reply to the list - very helpful.
> 
> On 7/6/05, Peter Beutner <p.beutner at gmx.net> wrote:
>>Appearently there are two things which let mythtv hang during channel scan:
>>- as the driver always reports a signal lock mythtv waits forever when
>>it has tuned to a frequency where is no signal at all
>>- a filter mask(other than 0xff) for section filter doesnt work
>>I attach two patches which should resolve these issues. The first one,
>>implementing the signal status readout, should be pretty safe. Im using
>>it quite some time now. Just hadn't found time to send it here. The
>>second one is more a better guess, but it seems to do the right thing,
>>eg channel scanning with mythtv works for me. Hope it doesnt break any
>>other stuff, although I think it shouldnt ...
>>So you may give them a try ;)
> Thanks - I patched the files concerned (manually - for some reason the
> patches wouldn't take), and they compiled, when I found a version in
> CVS I can use!  Apparently dvb-kernel CVS swapped over to insisting on
> 2.6.13rc+ yesterday? Anyway, I've patched CVS code from the 6th June
> (using 2.6.12.2 here).
hmm iirc the dvb patches are still in -mm tree, but probably will be in 
2.6.13-rc3. But my patches were against the dvb-kernel cvs. Dunno why 
they failed to apply. But seems you get it anyway ;)
So does scanning in mythtv work now?

It seems there is still something wrong with the section filters as 
updating the epg over dvb doesnt work in mythtv.

>>I guess the decoder chip on the box locks up. If you look in your kernel
>>log when that happens, you probably will see lots of "bulk message
>>failed" errors. At least I see this quite often here after some channel
>>zapping. Im still trying to find the real reason for these lockups.
> 
> No I don't see any such messages, unless I need to turn verbosity up somewhere?
> Again last night, same experience - I managed to tune into one channel
> with tzap -> mplayer, which locked up after maybe 10 seconds, and now
> I can't tune into any. I had no problems whatsoever in dvb-kernel/apps
> from 2004-12-26 and an earlier 2.6 kernel, so I'm really stuck here. 
> Is there anything else I can do or am I stranded with dvb-kernel now
> and this box?
You could load the ttusb_dec module with debug=1 as parameter.
But it seems it is a different error than the one I have.
As there hasnt really changend something in tzap, the error must 
somewhere in the kernel.You could try out which kernel version exactly 
has broken it, but that would be a rather painfull job :/
But maybe the debug logs show something interesting.

Peter

> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 
> 





More information about the linux-dvb mailing list