[linux-dvb] voltage control for DVB-T and DiSEqC switches

Kenneth Aafløy kenneth at linuxtv.org
Sat Jul 23 22:59:17 CEST 2005


lørdag 23. juli 2005, 09:45, skrev Dominik Strasser:
> Andreas Oberritter wrote:
> >Well, it makes sense as long as the enum is used only for satellite
> >receivers. It probably means "Satellite Equipment Control".
>
> You could maintain backward compatibility + new more accurate names by 
> doing something like this:

Yup!

>  typedef enum fe_sec_voltage {
> - SEC_VOLTAGE_13,
> - SEC_VOLTAGE_18,
> - SEC_VOLTAGE_OFF
> + SEC_VOLTAGE_13 = 0,  /* 13V DVB-S vertical */
> + SEC_VOLTAGE_18 = 1,  /* 18V DVB-S horizontal */
> + SEC_VOLTAGE_OFF = 2, /*  0V DVB-S / -T standby / passive antenna */
> + SEC_VOLTAGE_5 = 3,  /*  5V DVB-T active antenna */
> + SEC_VOLTAGE_12 = 4  /* 12V DVB-S DiSEqC */
> + VOLTAGE_13 = 0,  /* 13V DVB-S vertical */
> + VOLTAGE_18 = 1,  /* 18V DVB-S horizontal */
> + VOLTAGE_OFF = 2, /*  0V DVB-S / -T standby / passive antenna */
> + VOLTAGE_5 = 3,  /*  5V DVB-T active antenna */
> + VOLTAGE_12 = 4  /* 12V DVB-S DiSEqC */
>  } fe_sec_voltage_t;
> + 
> +  typedef fe_sec_voltage_t fr_voltage_t;

I love this, except for the namespace issues, make it be prefixed
by FE_/DVB_ instead.

Kenneth




More information about the linux-dvb mailing list