[linux-dvb] voltage control for DVB-T and DiSEqC switches

Felix Domke tmbinc at elitedvb.net
Sun Jul 24 23:10:37 CEST 2005


Johannes Stezenbach wrote:
> Kenneth Aafløy wrote:
>>>> typedef enum fe_sec_voltage {
>>>>- SEC_VOLTAGE_13,
>>>>- SEC_VOLTAGE_18,
>>>>- SEC_VOLTAGE_OFF
>>>>+ SEC_VOLTAGE_13 = 0,  /* 13V DVB-S vertical */
>>>>+ SEC_VOLTAGE_18 = 1,  /* 18V DVB-S horizontal */
>>>>+ SEC_VOLTAGE_OFF = 2, /*  0V DVB-S / -T standby / passive antenna */
>>>>+ SEC_VOLTAGE_5 = 3,  /*  5V DVB-T active antenna */
>>>>+ SEC_VOLTAGE_12 = 4  /* 12V DVB-S DiSEqC */
>>>>+ VOLTAGE_13 = 0,  /* 13V DVB-S vertical */
>>>>+ VOLTAGE_18 = 1,  /* 18V DVB-S horizontal */
>>>>+ VOLTAGE_OFF = 2, /*  0V DVB-S / -T standby / passive antenna */
>>>>+ VOLTAGE_5 = 3,  /*  5V DVB-T active antenna */
>>>>+ VOLTAGE_12 = 4  /* 12V DVB-S DiSEqC */
>>>> } fe_sec_voltage_t;
>>>>+ 
>>>>+  typedef fe_sec_voltage_t fr_voltage_t;
>>>I love this, except for the namespace issues, make it be prefixed
>>>by FE_/DVB_ instead.
> I think I like the original version better, because it makes
> the minimal change and keeps confusion at a minimum.
Though the idea isn't bad, i agree with Johannes, we should keep the
confusion at minimum, even for the price of having incorrect prefixes-

I agree that SEC is wrong here, but on the other hand, most people don't
even know what SEC means, so we could just use it as a prefix for "all
antenna power related stuff".

Of course we could change to a new prefix, but it wouldn't really help,
does it? (for example having AC_ instead of SEC_)

Bye the way, what's about adding an IOCTL to measure LNB current? (or
has this be proposed already?)

We're currently using this for detecting motor movements, in order to
check on pre-diseqc2 equipment that the motor has moved to the final
position.

Felix




More information about the linux-dvb mailing list