[linux-dvb] KNC1 DVB-S Plus

Julian Scheel julian at jusst.de
Sun Jul 31 13:05:34 CEST 2005


Am Sonntag, 31. Juli 2005 01:18 schrieben Sie:
> Thats right -- but its already supposedly being done in the driver :(
>
> Hmm, I reckon the CI code is mixing up the non-CI cards.. I was having a
> problem like this with my KNC-1-S (nonplus) with CI module.
>
> According to the budget-av.c, the GPIOs for CI are connected as follows:
>  * 0 - Vcc/Reset (Reset is controlled by capacitor)
>  * 1 - Attribute Memory
>  * 2 - Card Enable (Active Low)
>  * 3 - Card Detect
>
> However, I also found that GPIO2 controls the frontend on my DVBT card as
> well as the CI module card enable :(
>
> Try adding in:
>                         saa7146_setgpio(saa, 2, SAA7146_GPIO_OUTLO);
>
> in budget-av.c/frontend_init() in the bit where it does
> "Enable / PowerON Frontend"
>
> and see if that helps.
>
> Can you explain what the card does - i.e. in "video" mode, can you see a
> DVB signal at all - or is it only video in from the analogue connector on
> the card? I  seem to remember it was either-or, but I can't remember which
> GPIO does the switching.

I tried the additional GPIO2 control, but it didn't help  - I still get the 
message, that no frontend was found.
I am not sure if the card does either video or dvb mode - For video input it 
has an S-VHS connector.

The i2cdetect data hasn't changed with the GPIO2 control, too.

I wasn't able to spot an stv0299b-chipset on the card, but this may be, 
because of the closed tuner-box, so I can't look into it.

-Julian




More information about the linux-dvb mailing list