[linux-dvb] Antother problem with mt352

François-Xavier Payet Francois-Xavier.Payet at ens.insa-rennes.fr
Fri Mar 18 23:43:12 CET 2005


Thanks for the patch, but unfortunately, still the same problem (I'm sure the 
reception is good, working like a charm on windows)

FX

Le Vendredi 18 Mars 2005 23:11, vous avez écrit :
> On Friday 18 March 2005 22:28, Rainer Schubert wrote:
> > On Fri, 18 Mar 2005, [iso-8859-15] François-Xavier Payet wrote:
> > > My card is finally working quite well, but I still have got a problem
> > > The image is perfect for a few seconds, but then it become badder and
> > > badder
> >
> > With my card (300i) it's working for half an hour or more without errors,
> > but if I zap too fast from one channel to the next or even to a random
> > channel, I get the same read errors that you have seen.
> >
> > There are more registers than just reg=1 presenting problems with
> > reading, buit as I don't really know what they are doing, I can't be of
> > any use to you.
> >
> > > From the moment the image begins to get bad, dmesg gets me this message
> > > : mt352_read_register: readreg error (reg=1, ret==-5)
> > >
> > > Does anyone knows something about this?
> >
> > Maybe kraxel at bytesex.org (Gerd Knorr) can tell you what to do. If he
> > does, please let me know what he suggested.
>
> There is a comment about the STATUS_* registers in mt352.c that states that
> if they are read to fast the pinnacle might loose lock. Would you please
> care to try the attached patch, which limits the read to two times a sec?
>
> Kenneth




More information about the linux-dvb mailing list