[linux-dvb] [PATCH] gcc 2.95, again

Patrick Boettcher patrick.boettcher at desy.de
Sun Mar 20 00:13:13 CET 2005


On Sat, 19 Mar 2005 w-thiel at gmx.net wrote:

> On Sat, Mar 19, 2005 at 05:48:09PM +0100, Olaf Titz wrote:
>> PLEASE folks, make sure not to break gcc 2.95. Can't be that hard at
>> all. Until 3.x produces a kernel which does not crash DVB (3.3.3 does
>> not, will try 3.4.3 later) I'm recommending to stick with 2.95.
>>
> I have no problems with gcc 3.3.5 when compiling a kernel here.
> Of course, I appreciate your patch: IIRC, 2.95 is still recommended
> in the kernel sources.

Is there an option for 3.x gcc to produce warnings for 2.95 
incompatibilities?

Most of the gcc-2.95 error are in my drivers. I simply don't notice them, 
because it is working and the compiler doessn't moan.

regards,
Patrick




More information about the linux-dvb mailing list