[linux-dvb] tda1004x firmware upload problem

Kenneth Aafløy lists at kenneth.aafloy.net
Sat Mar 26 21:06:52 CET 2005


On Friday 25 March 2005 21:51, Mikko Rauhala wrote:
> I haven't been able to get the firmware of my Hauppage WinTV-USB DVB-T
> adapter to load under Ubuntu Hoary's 2.6.10 kernel. The module in
> question is tda1004x, and in the older Warty 2.6.8 kernel the driver
> loads the firmware fine from /usr/lib/hotplug/firmware/tda1004x.bin, and
> the device works.
> 
> This newer kernel loads the driver automatically nicely but the firmware
> just doesn't load, saying in dmesg:
> 
> usb 1-3: new full speed USB device using ohci_hcd and address 7
> ttusb_init_controller: dsp-version: 0.0
> DVB: registering new adapter (Technotrend/Hauppauge Nova-USB).
> DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
> usbcore: registered new driver Technotrend/Hauppauge USB-Nova
> [cut to where the DVB device is attempted to be used]
> tda1004x: waiting for firmware upload...
> tda1004x: no firmware upload (timeout or file not found?)

This is hotplug failing to upload the firmware.
(unless you are running out of memory, which is unlikely)

You should check that /etc/hotplug/firmware.agent is doing it's job correctly.

On my debian system, the directories searched for firmware is specified with:
FIRMWARE_DIRS="/lib/firmware /usr/local/lib/firmware /usr/lib/hotplug/firmware"

Check FIRMWARE_DIRS in firmware.agent first. Then assure that firmware.agent
is actually called, and that the firmware file is found.

Kenneth




More information about the linux-dvb mailing list