[linux-dvb] 2.6.13, TT DVB-C and video4linux

Gavin Hamill gdh at acentral.co.uk
Sun Oct 16 00:54:59 CEST 2005


Hi, I'm simply trying to get the video4linux interface working with my
TT full-feature card - something I've had working before with 2.6.10 or
so, but I wonder if I'm missing something with this new TT card...

DVB: registering new adapter (Technotrend/Hauppauge WinTV DVB-C rev2.X).
adapter has MAC addr = 00:d0:5c:03:dc:b6
dvb-ttpci: gpioirq unknown type=0 len=0
dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068,
app 80ff2621
dvb-ttpci: firmware @ card 0 supports CI link layer interface
dvb-ttpci: adac type set to 0 @ card 0
saa7146_vv: saa7146 (0): registered device video1 [v4l2]
DVB: registering frontend 0 (VLSI VES1820 DVB-C)...

So, I should expect a framegrabber to work on /dev/video1, which is not
the case :(

Even with my /dev files thusly forcing video0 to the same device as
video1:

crw-r--r--  1 root root  81, 1 2005-10-15 23:14 video0
crw-rw----  1 root video 81, 1 2005-09-03 23:05 video1

and running VDR's 'GRAB' command simply gives "451 Grab image failed". I
get similar failures from commandline v4l framegrabbers.

I do have these modules loaded:

v4l1_compat            13572  2 saa7146_vv,cx8800
v4l2_common             5888  2 saa7146_vv,cx8800
video_buf_dvb           6276  1 cx88_dvb
dvb_core               74792  2 dvb_ttpci,video_buf_dvb
video_buf              20484  7
cx88_dvb,saa7146_vv,video_buf_dvb,cx88_blackbird,cx8802,cx8800,cx88xx
videodev                9216  4 saa7146_vv,cx88_blackbird,cx8800,cx88xx

which I think should be enough - are there known issues with 2.6.13? I'd
like to avoid messing with more kernels if I can help it :)

Cheers,
Gavin.





More information about the linux-dvb mailing list