[linux-dvb] Compro DVB-T200 - saa7134-dvb not loading

James Sheridan james at pixelix.co.uk
Tue Oct 18 01:40:00 CEST 2005


Hi there,

I'm using Debian 'unstable', with the stock 2.6.12.1 kernel supplied with.

I'm having a lot of trouble getting this card initialised and working. 
I've followed the instructions given on the v4l wiki, which say to 
download the latest v4l_kernel and dvb_kernel sources from CVS, and to 
compile new modules from them (running the scripts/merge-trees.sh script, 
editing Make.config to build VIDEO_SAA7134_DVB as a module, etc) - which 
seemed to work fine.

I've also put the relevant firmware (dvb-fe-tda10046.fw, I believe) in
/lib/firmware. But upon loading the modules, I get the following in dmesg:

After loading the saa7134 module ('modprobe saa7134 card=71 tuner=1 
dsp_nr=1 mixer_nr=1 oss=1 oss_rate=32000'):

saa7130[0]: found at 0000:01:04.0, rev: 1, irq: 169, latency: 32, mmio: 0xf80100 00
saa7130[0]: subsystem: 185b:c901, board: Compro Videomate DVB-T200 [card=71,insm od option]
saa7130[0]: board init: gpio is 843f00
saa7130[0]: registered input device for IR
tuner 1-0061: chip found @ 0xc2 (saa7130[0])
tuner 1-0061: type set to 1 (Philips PAL_I (FI1246 and compatibles))
tuner 1-0068: chip found @ 0xd0 (saa7130[0])
saa7130[0]: i2c eeprom 00: 5a 10 00 c0 10 00 04 00 40 43 09 14 10 10 02 10
saa7130[0]: i2c eeprom 10: 00 d4 80 05 01 00 fa ff ef 58 1a 8d e0 00 00 50
saa7130[0]: i2c eeprom 20: 01 40 00 00 00 77 00 01 08 d4 00 00 04 83 fa c7
saa7130[0]: i2c eeprom 30: ff 96 bc 9b 7a 50 a0 d4 b8 14 04 77 f0 c3 1f d4
saa7130[0]: i2c eeprom 40: b8 10 00 82 82 10 ff 96 bc 9b 7d 80 bb d4 bc 14
saa7130[0]: i2c eeprom 50: 04 d4 b8 15 06 c0 01 d4 bc 15 06 d4 b8 15 06 c0
saa7130[0]: i2c eeprom 60: 30 04 0c 83 fa ff 7f 58 1a 2b 01 8d e0 00 00 50
saa7130[0]: i2c eeprom 70: 12 68 59 8d e2 00 00 50 82 ed 34 00 00 50 52 d4
saa7130[0]: registered device video0 [v4l2]
saa7130[0]: registered device vbi0

Which, I think - looks okay?

However, after loading saa7134-dvb ('modprobe saa7134-dvb'):

DVB: registering new adapter (saa7130[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
saa7130[0]: dvb_dmx_init failed (errno = -12)

Any ideas gratefully accepted!

Thanks

-- 
James.




More information about the linux-dvb mailing list