[linux-dvb] Problem loading dvb-bt8xx for FusionHDTV5 Lite

Luis Ochoa luis.m.ochoa at gmail.com
Tue Oct 18 06:04:26 CEST 2005


OK, that didn't work either. Plain vanilla kernel (latest stable
2.6.13.4) configured with "just" what I need. CVS v4l + dvb. Same
error. Now analog tv doesn't work either...

dmesg:
Linux video capture interface: v1.00
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt Link [LNK0] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:02:02.0[A] -> Link [LNK0] -> GSI 5 (level,
low) -> IRQ 5
bttv0: Bt878 (rev 17) at 0000:02:02.0, irq: 5, latency: 32, mmio: 0xdb100000
bttv0: detected: DViCO FusionHDTV 5 Lite [card=135], PCI subsystem ID
is 18ac:d500
bttv0: using: DViCO FusionHDTV 5 Lite [card=135,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=64
tuner 0-0043: chip found @ 0x86 (bt878 #0 [sw])
tuner 0-0043: type set to 64 (LG TDVS-H062F/TUA6034)
tuner 0-0061: chip found @ 0xc2 (bt878 #0 [sw])
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: add subdevice "dvb0"
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:02:02.1[A] -> Link [LNK0] -> GSI 5 (level,
low) -> IRQ 5
bt878(0): Bt878 (rev 17) at 02:02.1, irq: 5, latency: 32, memory: 0xdb101000

............

#modprobe -v dvb-bt8xx
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/lgdt330x.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/or51211.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/cx24110.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/dvb-core/dvb-core.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/bt8xx/dst.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/bt8xx/dst_ca.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/sp887x.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/dvb-pll.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/mt352.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/frontends/nxt6000.ko
insmod /lib/modules/2.6.13.4-MythBackend/kernel/drivers/media/dvb/bt8xx/dvb-bt8xx.ko

dmesg:

DVB: registering new adapter (bttv0).
dvb_bt8xx: dvb_dmx_init failed (errno = -12)
dvb-bt8xx: probe of dvb0 failed with error -12

On 10/16/05, Luis Ochoa <luis.m.ochoa at gmail.com> wrote:
> Thanks, I'll try that.
>
> I realized that I wasn't completely correct before, I didn't follow
> the instructions of not installing ANY driver kernels (step 1in the
> Wiki). I couldn't even get analog working (using tvtime) so I
> recompiled the FC4 kernel with no drivers, and then added CVS, and I
> got Analog (although just video, how do you get analog audio from this
> board? do you have to use a patch cable between it and the sound
> card?) but the dvb error was still there.
>
> I'll try a vanilla kernel.
>
> Thanks again, Luis.
>
> On 10/16/05, Michael Krufky <mkrufky at linuxtv.org> wrote:
> > Luis Ochoa wrote:
> > > Hi all,
> > > I have the latest CVS dvb-kernel and v4l-kernel compiled and installed
> > > as per the Wiki.
> > > Here's the info...any ideas? Thanks!
> > >
> > > uname -r:
> > > 2.6.13-1.1526_FC4
> > >
> > [snip]
> > > Oct 15 22:00:16 localhost kernel: DVB: registering new adapter (bttv0).
> > > Oct 15 22:00:16 localhost kernel: dvb_bt8xx: dvb_dmx_init failed (errno = -12)
> > > Oct 15 22:00:16 localhost kernel: dvb-bt8xx: probe of dvb0 failed with error -12
> >
> > I've heard this problem from many users of FC4 kernel.... Try a vanilla
> > 2.6.13.y kernel from kernel.org ... Then install merged cvs on top of that.
> >
> > This is a DVB problem, and it is NOT local to FusionHDTV5 Lite, or
> > dvb-bt8xx.
> >
> > --
> > Michael Krufky
> >
>



More information about the linux-dvb mailing list