[linux-dvb] FIX: No recovery after lost lock

Andrew de Quincey adq_dvb at lidskialf.net
Sun Sep 4 16:11:05 CEST 2005


On Sunday 04 Sep 2005 14:47, Jon Burgess wrote:
> Andrew de Quincey wrote:
> > Removing the code obviously means that it will always cycle through the
> > inversions when lock is accidentally lost. I don't understand why that is
> > necessary though - perhaps we have a bug in the frontend driver?
>
> I reckon that the FE is indicating lock when it shouldn't be, either it
> happens at random or perhaps something like this happens because we
> don't give the FE enough time to update the lock status. Perhaps the
> "min_delay" parameter needs increasing for this FE?
>
> It looks like most callers set min_delay_ms = 100:
>
> [jburgess at t41 dvb]$ grep -r "\.min_delay_ms" .
> ./ttusb-budget/dvb-ttusb-budget.c:      .min_delay_ms = 100,
> ./b2c2/flexcop-fe-tuner.c:      .min_delay_ms = 100,
> ./ttpci/budget-av.c:    .min_delay_ms = 100,
> ./ttpci/budget-av.c:    .min_delay_ms = 100,
> ./ttpci/budget-patch.c: .min_delay_ms = 100,
> ./ttpci/budget-ci.c:    .min_delay_ms = 100,
> ./ttpci/budget-ci.c:    .min_delay_ms = 50,
> ./ttpci/av7110.c:       .min_delay_ms = 100,
> ./ttpci/av7110.c:       .min_delay_ms = 100,
> ./ttpci/budget.c:       .min_delay_ms = 100,
>
> Interestingly the odd-one-out at 50ms is the philips_su1278_tt_config
> which was the one implicated by Marian in the start of this thread:
>
>    kernel: DVB: registering new adapter (TT-Budget/WinTV-NOVA-CI PCI).
>    kernel: stv0299: try to attach to TT-Budget/WinTV-NOVA-CI PCI
>    kernel: stv0299: setup for tuner SU1278 (TSA5059 synth) on
> TechnoTrend hardware
>
> Perhaps we should try increasing this to 100ms for this one too. Patch
> attached.

Yup. I'm just getting my test environment setup on the site with the issue... 
will let you know if it helps.



More information about the linux-dvb mailing list