[linux-dvb] FIX: No recovery after lost lock

Andrew de Quincey adq_dvb at lidskialf.net
Tue Sep 27 12:01:00 CEST 2005


On Friday 23 Sep 2005 05:04, Oliver Endriss wrote:
> Johannes Stezenbach wrote:
> > On Wed, Sep 21, 2005 Oliver Endriss wrote:
> > > Imho the 'enhanced' code looks broken:
> >
> > cvs annotate blames this to Andrew, maybe he can enlighten us?
> > Otherwise, if it is obviously broken we should just remove it.
>
> Yep, the fine-tuning code was introduced in Rev 1.31:
> | Revision 1.31 - (view) (download) (as text) (annotate) - [select for
> | diffs] Mon Feb 23 23:20:29 2004 UTC (18 months, 4 weeks ago) by quincy
> |
> | Fixes to sort out tuning at low symbol rates
>
> Hm, I turned-on the fine-tuning code for my BSRU6 tuner and did some
> tests.
>
> Imho this code can be fixed by moving
> 	state->tuner_frequency = p->frequency;
> into the else clauses. tuner_frequency must not be set for fine-tuning.
>
> Anyway, recovery seems to be faster without fine-tuning, at least with
> my Nexus, higher symbol rates and a good signal...

Hmm, weird, I added the enhanced code because thats what hauppauge appeared to 
be doing, and I thought it seemed to work better at the time.... however 
looks like that isn't the case. I've no problem if you want to rip it out.

BTW: I finally tracked down why I was having extreme lock problems on one site 
- satellite installer problem - they'd mounted the arm with the LNB on it out 
of position!! (and they claimed they'd tested it!)



More information about the linux-dvb mailing list