[linux-dvb] Pinnacle 300i

Rainer Schubert lintv at dl6hbo.inka.de
Fri Feb 3 16:30:51 CET 2006


On Thu, 2 Feb 2006, hermann pitton wrote:

> Hello,

Hi Herrmann,

[...]
>> Same here with recent kernels. The best setup ever was with kernel
>> 2.6.12.5 and the video4linux-archive as of 27062005 from bytesex.org.
>
> that it is not detected and also doesn't work in analog mode I would
> expect to be caused by an error in a recent patch, which announced to
> force tda9887 port2=1 INACTIVE, but unfortunately did the opposite
> port2=0 ACTIVE then and the analog tuner becomes invisible on this card.
> The suspicious thing is that this was previously not needed at all.

Nerver noticed the analog part does not work, as in my area there is
almost not analog TV any more (Hamburg).

> You can change this in saa7134-cards.c for the 300i or load tda9887 with
> "port2=1". After you quit digital tuning the driver should do this too
> in saa7134-dvb.c to prepare the card for analog use again.

Good advice, thank you.

> Seems to fail? Since I neither have the card nor any specific idea of
> what is broken in digital mode, my suggestion is only to enable
> i2c_debug=1 and gpio_tracking=1 for saa7134 and maybe debug=2 for
> tda9887 and follow every single buffer looking for errors and maybe also
> compare the working stuff with the broken then.

Well I suspect the saa7134 code, as driver versions 0.2.12 and 0.2.13
have been working for me, but later versions did not.
[...]

Rainer
-- 
Rainer Schubert - Linux TV User
Amateur Radio Call DL6HBO



More information about the linux-dvb mailing list