[linux-dvb] nova-T and 2.6.15 no adapter0 but appears in dmesg

Paul Wheeler paulrwheeler at gmail.com
Sun Jan 8 19:36:43 CET 2006


On 1/8/06, Michael Krufky <mkrufky at m1k.net> wrote:
> Paul Wheeler wrote:
>
> >I have just installed a nova-t pci card alongside my avermedia 771.
> >The avermedia works fine with out any problem. However on a new
> >install of 2.6.15 on gentoo i cant seem to detect the adapter for the
> >nova-t below is dmesg and dev results. Has naybody else been able to
> >get it working with 2.6.15? Am I missing a kernel option?? It seems
> >dmesg is finding adapter0 but I cannot find the adapter0 in /dev I am
> >also using udev v79.
> >
> >dmesg:
> >
> >
> >Linux video capture interface: v1.00
> >bttv: driver version 0.9.16 loaded
> >bttv: using 8 buffers with 2080k (520 pages) each for capture
> >bttv: Bt8xx card found (0).
> >ACPI: PCI Interrupt 0000:02:0a.0[A] -> GSI 22 (level, low) -> IRQ 16
> >bttv0: Bt878 (rev 17) at 0000:02:0a.0, irq: 16, latency: 64, mmio: 0xe7bfe000
> >bttv0: detected: AVermedia AverTV DVB-T 771 [card=123], PCI subsystem
> >ID is 1461:0771
> >bttv0: using: AVerMedia AVerTV DVB-T 771 [card=123,autodetected]
> >bttv0: gpio: en=00000000, out=00000000 in=00dfffdf [init]
> >bttv0: using tuner=4
> >bttv0: registered device video0
> >bttv0: registered device vbi0
> >bttv0: PLL: 28636363 => 35468950 .. ok
> >bttv0: add subdevice "remote0"
> >bttv0: add subdevice "dvb0"
> >input: i2c IR (Hauppauge) as /class/input/input1
> >input: bttv IR (card=123) as /class/input/input2
> >cx2388x v4l2 driver version 0.0.5 loaded
> >ACPI: PCI Interrupt 0000:02:0c.0[A] -> GSI 20 (level, low) -> IRQ 17
> >CORE cx88[0]: subsystem: 0070:9002, board: Hauppauge Nova-T DVB-T
> >[card=18,autodetected]
> >TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
> >tveeprom 1-0050: Hauppauge model 90002, rev C176, serial# 188320
> >tveeprom 1-0050: MAC address is 00-0D-FE-02-DF-A0
> >tveeprom 1-0050: tuner model is Thompson DTT7592 (idx 76, type 4)
> >tveeprom 1-0050: TV standards ATSC/DVB Digital (eeprom 0x80)
> >tveeprom 1-0050: audio processor is None (idx 0)
> >tveeprom 1-0050: decoder processor is CX882 (idx 25)
> >tveeprom 1-0050: has no radio, has IR remote
> >cx88[0]: hauppauge eeprom: model=90002
> >input: cx88 IR (Hauppauge Nova-T DVB-T as /class/input/input3
> >cx88[0]/0: found at 0000:02:0c.0, rev: 5, irq: 17, latency: 64, mmio: 0xec000000
> >cx88[0]/0: registered device video1 [v4l2]
> >cx88[0]/0: registered device vbi1
> >cx2388x blackbird driver version 0.0.5 loaded
> >cx2388x dvb driver version 0.0.5 loaded
> >ACPI: PCI Interrupt 0000:02:0c.2[A] -> GSI 20 (level, low) -> IRQ 17
> >cx88[0]/2: found at 0000:02:0c.2, rev: 5, irq: 17, latency: 64, mmio: 0xed000000
> >cx88[0]/2: cx2388x based dvb card
> >DVB: registering new adapter (cx88[0]).
> >DVB: registering frontend 0 (Conexant CX22702 DVB-T)...
> >bt878: AUDIO driver version 0.0.0 loaded
> >bt878: Bt878 AUDIO function found (0).
> >ACPI: PCI Interrupt 0000:02:0a.1[A] -> GSI 22 (level, low) -> IRQ 16
> >bt878(0): Bt878 (rev 17) at 02:0a.1, irq: 16, latency: 64, memory: 0xe7bff000
> >DVB: registering new adapter (bttv0).
> >DVB: registering frontend 1 (Zarlink MT352 DVB-T)...
> >
> >/dev/dvb:
> >drwxr-xr-x   2 root root   120 Jan  8 17:49 adapter1
> >
> >/dev/v4l:
> >crw-rw----   1 root video 81, 224 Jan  8 17:49 vbi0
> >crw-rw----   1 root video 81, 225 Jan  8 17:49 vbi1
> >crw-rw----   1 root video 81,   0 Jan  8 17:49 video0
> >crw-rw----   1 root video 81,   1 Jan  8 17:49 video1
> >
> >
> >Cheers
> >Paul
> >
> >_______________________________________________
> >linux-dvb mailing list
> >linux-dvb at linuxtv.org
> >http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> >
> >
> modprobe cx88-dvb
>
All the options are compiled in and are not modules. (there is no
cx88-dvb module to be able to modprobe)

Paul



More information about the linux-dvb mailing list