[linux-dvb] FE_SET_TONE fails on Nexus with CI

Michael Ditum mike at mikeditum.co.uk
Tue Jun 6 16:24:02 CEST 2006


I am currently getting errors when trying to tune in a Nexus rev 2.2 card
which has a CI.

I get the error in dvbtune and in vlc, though the error only occurs in
dvbtune every now and then.

dvbtune returns with the error message "DISEQC SETTING FAILED" and I have
tracked it down in the code to when it tries to set the tone.

vlc fails to set it everytime and outputs the following messages

[00000252] [Media: channel0] dvb access error: ioctl FE_SET_TONE failed,
tone=on (-1) Connection timed out
[00000252] [Media: channel0] dvb access error: DVB-S: tuning failed
[00000252] [Media: channel0] dvb access error: ioctl FE_SET_TONE failed,
tone=on (-1) Connection timed out
[00000252] [Media: channel0] dvb access error: DVB-S: tuning failed

I have the latest code from the main hg branch (as of this morning) and am
running it under 2.6.14.

I am trying to tune to the following transponder on Hotbird 2:

Frequency: 12092000
Symbol rate: 27500
Polarization: Horizontal
FEC: 3_4

I tried setting the following options in modprobe.conf before modprobing the
drivers but couldn't see any useful error messages...

options dvb-core debug=1 dvbdev_debug=1 frontend_debug=1
options dvb_ttpci debug=1
options saa7146 saa7146_debug=99

Does anyone have any ideas on what the problem could be or what I could do
to get more logging info?

Mike
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060606/e3cc2576/attachment.htm


More information about the linux-dvb mailing list