[linux-dvb] [Fwd: DVB stream after using composite video in on Mythtv]

Paul Wilson paul at wilsononline.id.au
Wed Jun 7 14:17:41 CEST 2006


With the latest HG modules this has improved a tiny bit.. the below 
message do-not appear but the problem still exists when I use the V4L 
driver and then attempt to use the DVB driver for this card.
Would this be a bug with V4L and DVB or MythTV?

Paul

-------- Original Message --------
Subject: 	DVB stream after using composite video in on Mythtv
Date: 	Fri, 17 Mar 2006 19:17:46 +1100
From: 	Paul Wilson <paul at wilsononline.id.au>
To: 	linux-dvb at linuxtv.org



I have a DNTV-Live Pro PCI card using the cx88 chipset , I have setup my 
card in Mythtv + V4L drivers for the Composite video in.
I Started recording the DVB-T stream and then start using the Composite 
(video-in) which stops the DVB input and I see a flood of the following 
messages .

Q1. What do these messages mean.
Q2. Can I using both the DVB + Composie on my Hybrid card at the same time..

I believe in the Windows environment the drivers and s/w can do this,
but do the DVB modules in DVB-Linux allow this?

dmesg output:

tda9887 3-0043: i2c i/o error: rc == -121 (should be 4)
cx88[0]/2: queue is empty - first active
cx88[0]/2: cx8802_start_dma w: 0, h: 0, f: 2
cx88[0]/2: setting the interrupt mask
cx88[0]/2: [c31375c0/0] cx8802_buf_queue - first active
cx88[0]/2: cx8802_restart_queue
cx88[0]/2: cx8802_restart_queue: queue is empty
cx88[0]/2: queue is empty - first active
cx88[0]/2: cx8802_start_dma w: 0, h: 0, f: 2
cx88[0]/2: setting the interrupt mask
cx88[0]/2: [cbf244c0/0] cx8802_buf_queue - first active
cx88[0]/2: cx8802_restart_queue
cx88[0]/2: cx8802_restart_queue: queue is empty
cx88[0]/2: queue is empty - first active
cx88[0]/2: cx8802_start_dma w: 0, h: 0, f: 2
cx88[0]/2: setting the interrupt mask
cx88[0]/2: [c31375c0/0] cx8802_buf_queue - first active
cx88[0]/2: cx8802_timeout
cx88[0]/2: cx8802_stop_dma
cx88[0]/2: restarting queue
cx88[0]/2: cx8802_restart_queue
cx88[0]/2: cx8802_restart_queue: queue is empty
cx88[0]/2: queue is empty - first active
cx88[0]/2: cx8802_start_dma w: 0, h: 0, f: 2
cx88[0]/2: setting the interrupt mask

Has any other the latest changes in the CVS affect this bugs/feature?

Any advice or information would be appreciated,
note is there any more debugging that would help diagnose this problem?

Thanks
Paul


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060607/afd057a5/attachment.htm


More information about the linux-dvb mailing list