[linux-dvb] [PATCH] Multi protocol support (stage #1)

Alan Nisota alannisota at gmail.com
Wed Jun 14 05:40:14 CEST 2006


On 6/13/06, Yeasah Pell wrote:
> Ok, sorry about the confusion. I think I now see where I got lost in
> your original response. If I'm now understanding you correctly, then I
> would answer Alan's original question:
>
> > Alan Nisota wrote:
> > ...
> >> Specifically, if the API is version 3.2, does that mean that all cards
> >> can be accessed with the new DVBFE ioctls (which would make things
> >> relatively nice, as an app needs to support only one or the other as
> >> defined at compile-time), or does each driver need to be ported to use
> >> the new API, in which case there needs to be some way to designate
> >> which cards support the new drivers?
> >
>
> With simply "all cards will be accessible through the new DVBFE ioctls."
> Right?
This is the answer I would prefer.  It greatly simplifies the coding
if we can determine at compile time which API to use rather than
needing to do so on the fly during execution.

Alan



More information about the linux-dvb mailing list