[linux-dvb] ASUS P7131 DUAL DVB-T enable dvb-t asus p7131 dual + fm saa7134

Hartmut Hackmann hartmut.hackmann at t-online.de
Thu Jun 22 00:43:06 CEST 2006


hi

franck desbois wrote:
> hello hartmut
> 
>  i don't understand very well, cause my english is poor :((
> 
Don't worry, you should hear my french ;-)

> this is the correct channel.conf for paris ( xine and mplayer):
> 
> TF1:562167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:1537
> France2:586167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:120:130:257
> France3:586167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:220:230:273
> Canal+:522167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:160:80:769
> France5:586167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:320:330:260
> M6:498167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:1025
> ARTE:586167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:520:530:261
> Direct8:474167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:160:80:513
> W9:498167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:220:230:1026
> TMC:474167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:161:84:514
> NT1:498167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:320:330:1027
> NRJ12:562167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:220:230:1538
> LCP:586167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:620:630:262
> France4:586167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:420:430:259
> I>TV:474167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:516
> BFMTV:474167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:515
> EUROPE2:474167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:517
> GULLI:474167000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_NONE:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:518
> 
> and the correct fr-Paris is ( xine and mplayer):
> 
> # Paris - France (DVB-T transmitter of the Eiffel tower)
> # T freq bw fec_hi fec_lo mod transmission-mode guard-interval hierarchy
> T 474167000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 498167000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 522167000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 562167000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 586167000 8MHz 3/4 NONE QAM64 8k 1/8 NONE
> 
> however i have an another usb dvb-t card with a firmware dvb-usb-dtt200u-01.fw and any problem without to change my fr-Paris like this:
> 
> # Paris - France (DVB-T transmitter of the Eiffel tower)
> # T freq bw fec_hi fec_lo mod transmission-mode guard-interval hierarchy
> T 474000000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 498000000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 522000000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 562000000 8MHz 2/3 NONE QAM64 8k 1/32 NONE
> T 586000000 8MHz 3/4 NONE QAM64 8k 1/8 NONE
> 
Yes, this is known. Some channel decoders can lock with this offset, the current tda10046  driver
can't. But the upper values are the right ones.

> i have an another problem my fm-radio don't want to work witht gnomeradio or gradio:((
> 
> this is a part of my dmesg:2.6.15-25-k7 ( 25-43) ubuntu 6.06 
> 
> [17179588.984000] saa7133[0]: subsystem: 1043:4862, board: ASUSTeK P7131 Dual [c ard=78,autodetected]
> [17179588.984000] saa7133[0]: board init: gpio is 40000
> [17179588.984000] **** SET: Misaligned resource pointer: f7528e42 Type 07 Len 0
> [17179588.984000] ACPI: PCI Interrupt Link [APC4] enabled at IRQ 19
> [17179588.984000] ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [APC4] -> GSI 19 ( level, high) -> IRQ 209
> [17179588.984000] NVRM: loading NVIDIA Linux x86 Kernel Module  1.0-8762  Mon Ma y 15 13:06:38 PDT 2006
> [17179589.196000] eth1: link up.
> [17179589.212000] saa7133[0]: i2c eeprom 00: 43 10 62 48 54 20 1c 00 43 43 a9 1c  55 d2 b2 92
> [17179589.212000] saa7133[0]: i2c eeprom 10: 00 01 20 00 ff 20 ff ff ff ff ff ff  ff ff ff ff
> [17179589.212000] saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 03 08 ff 00 d6  ff ff ff ff
> [17179589.212000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff  ff ff ff ff
> [17179589.212000] saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 00 ff ff  ff ff ff ff
> [17179589.212000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff  ff ff ff ff
> [17179589.212000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff  ff ff ff ff
> [17179589.212000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff  ff ff ff ff
> [17179589.336000] tuner 2-004b: chip found @ 0x96 (saa7133[0])
> [17179589.336000] tuner-core.c: no tuner extensions loaded!
> [17179589.336000] tuner-core.c: no tuner extensions loaded!
> [17179589.384000] tuner 2-004b: setting tuner address to 61
> [17179589.424000] tuner 2-004b: type set to tda8290+75a
> [17179589.488000] saa7133[0]: registered device video1 [v4l2]
> [17179589.488000] saa7133[0]: registered device vbi0
> [17179589.488000] saa7133[0]: registered device radio0
> [17179589.500000] saa7134 ALSA driver for DMA sound loaded
> [17179589.500000] saa7133[0]/alsa: saa7133[0] at 0xe8000000 irq 201 registered a s card -1
> 
> tv analog doesn't work too :d:d: with tvtime and xawtv

did you add a:
options tuner secam=l
to your modprobe.conf file. This really is necressary for analog tv in france.
for analog sound, you should have the analog sound cable conected in the PC.
If not, you need a tool like sox.

Hartmut



More information about the linux-dvb mailing list