[linux-dvb] KNC1 DVB-C Plus + CI - still failing :(

Andrew de Quincey adq_dvb at lidskialf.net
Wed Jun 28 23:40:17 CEST 2006


On Thursday 15 June 2006 10:04, Bastian Friedrich wrote:
> Hi,
>
> I have recently installed a new DVB-C card to my system:
> * KNC One TV Station DVB-C Plus
> * CineView CI Module
> * AlphaCrypt Light CAM
> * Smartcard "Kabel Digital Home" (German Pay TV)
>
> The DVB card itself worked fine with budget-av (default Kernel 2.6.16.13
> drivers from SuSE 10.1's default-kernel), but the CI module was not
> even recognized (no output in dmesg, no /dev/dvb/adapter0/ca0). I
> installed the most recent mercurial checkout version, but was still
> unable to get the CI working.
>
> ciintf_init is not called for my card (I have no idea what saa7113
> is...). When "patching"
>         if (!budget_av->has_saa7113) {
>                 ciintf_init(budget_av);
>         } else {
>                 printk(KERN_INFO "Initializing CI despite saa7113\n");
>                 ciintf_init(budget_av);
>         }
> both encrypted as well as unencrypted programs work fine. I am aware of
> the fact that this might not be the case for other users...
>
> Anyway, unfortunately there still seems to be something wrong with the
> KNC CI support in budget-av.

Looking at the most likely card on KNC1.com, the problem is the card supports 
analogue inputs *AND* a CI module. Previous cards didn't support this, so the 
driver is set up to assume if it sees an saa7113 chip (for the extra inputs), 
then the card cannot have a CI module.

This would have to be investigated by trying combinations out to see what 
works -  or else by asking the manufacturer for information.



More information about the linux-dvb mailing list