[linux-dvb] Couple of question regarding installation

Klaus Frahm frahm at irsamc.ups-tlse.fr
Sun Oct 15 20:58:26 CEST 2006


Florian Lindner wrote:
> Am Samstag, 14. Oktober 2006 22:16 schrieb Klaus Frahm:
> 
>> > Am Samstag, 14. Oktober 2006 16:35 schrieb Patrick Boettcher:
>> > > Where is the driver from you are using? Can you try the drivers from
>> > > latest hg (v4l-dvb)?
>> >
>> > I'm using only the drivers from the kernel (2.6.17.6) and the
>> > firmware. No other drivers? Do I need to v4l userscape stuff?
>> >
>> > horus linux # grep DVB .config
>> > CONFIG_DVB=y
>> > CONFIG_DVB_CORE=m
>> > CONFIG_DVB_USB=m
>> > CONFIG_DVB_USB_A800=m
>> > CONFIG_DVB_DIB3000MC=m
>> >
>> >
>> > Thanks,
>> >
>> > Florian
>>
>>Dear Florian,
>>
>>I am using the same DVB-T Tuner AverTV A800 USB 2.0 and it works fine
>>but there are some particularities/bugs/patches to take into account:
> 
> 
> [...]
> 
> Thanks a lot! It's working perfect with 2.6.18.1 with the patch on the first 
> try!
> 
> Do you know when the patch will be integrated in the official kernel?
> 
> Regards,
> 
> Florian
> 

Actually the patch is already integrated in the official kernel, i.e. it 
is in 2.6.19-rc1 and 2.6.19-rc2 (which just came out this morning). 
Unfortunately, the v4l-driver with these two kernel versions still 
contain the other new mpeg-corruption bug which I mentioned. However, 
the latested v4l-tree is okay since 2-3 days and one can savely use the 
latested v4l-tree to install the drivers with the 2.6.19-rc1/2 kernel if 
you want to test these kernels. I suppose at latest with 2.6.19-final 
everything will be okay, probably earlier with 2.6.19-rc3 or -rc4.

Some time ago I was hoping that the patch would be in 2.6.18 but there 
was a delay because it had to be tested and first integrated in 
Patrick's tree, then transfered to the v4l-tree and then to the official 
kernel. In any case, when you upgrade your kernel using the 
kernel-patches this does normally not interfere with your own particular 
patches of this type provided that the kernel-upgrade-patches do not 
interfere with the file a800.c. In this way I did all rc-versions from 
2.6.17 to 2.6.18.

Greetings, Klaus.



More information about the linux-dvb mailing list