[linux-dvb] nobody using snd-usb-audio here, I am getting crazy.

kevin liu lwtbenben at gmail.com
Tue Dec 4 07:43:26 CET 2007


> you cannot playback anything on your tv tuner device, onl capture audio data.
>
> try arecord -l

Dear Markus,
    I cat /proc/asound/pcm, getting
""""""""""""""""""""""""""""""""""""""""""
kevin at ubuntukevin:~$ cat /proc/asound/pcm
00-01: CMI9880 Digital : CMI9880 Digital : playback 1 : capture 1
00-00: CMI9880 : CMI9880 : playback 1 : capture 2
01-00: USB Audio : USB Audio : capture 1
"""""""""""""""""""""""""""""""""""""""""""
    I arecord -l, getting
"""""""""""""""""""""""""""""""""""""""""""""""""""
kevin at ubuntukevin:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CMI9880 [CMI9880]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 0: Intel [HDA Intel], device 1: CMI9880 Digital [CMI9880 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Controlle [USB 2.0 Video Capture Controlle], device 0: USB
Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
""""""""""""""""""""""""""""""""""""""""""""""""""""""
    I think using
            arecord -D hw:1,0 -r 48000 -c 2 -f S16_LE | aplay -D hw:0,0
    will give me the correct sound, but this also doesn't work for me.
    And last night I play the sound correctly by accident, however,
after I replugged my tv card, the sound went away and I can not get it
anymore.
   Strangely. :-(



More information about the linux-dvb mailing list