[linux-dvb] cx88-dvb modprobe failure

Michael Krufky mkrufky at linuxtv.org
Fri Jun 1 18:05:57 CEST 2007


Sid Boyce wrote:
> Sid Boyce wrote:
>> Michael Krufky wrote:
>>> Sid Boyce wrote:
>>>>   # modprobe cx88-dvb
>>>> FATAL: Error inserting cx88_dvb 
>>>> (/lib/modules/2.6.22-rc3-smp/kernel/drivers/media/video/cx88/cx88-dvb.ko): 
>>>> No such device
>>>>
>>>> dmesg spits this out after trying "modprobe cx88-dvb"
>>>> cx2388x dvb driver version 0.0.6 loaded
>>>> cx8802_register_driver() ->registering driver type=dvb access=shared
>>>> # l /dev/vbi*
>>>> lrwxrwxrwx 1 root root        4 2007-05-30 06:24 /dev/vbi -> vbi0
>>>> crw-rw---- 1 root video 81, 224 2007-05-30 06:24 /dev/vbi0
>>>> crw-rw---- 1 root video 81, 225 2007-05-30 06:24 /dev/vbi1
>>>> /dev/dvb is not created.
>>>>
>>>>  From dmesg
>>>> ============
>>>> cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
>>>> cx2388x v4l2 driver version 0.0.6 loaded
>>>>
>>>> x2388x dvb driver version 0.0.6 loaded
>>>> cx8802_register_driver() ->registering driver type=dvb access=shared
>>>>
>>>> ACPI: PCI Interrupt 0000:01:08.0[A] -> Link [APC3] -> GSI 18 (level, 
>>>> low) -> IRQ 18
>>>> CORE cx88[0]: subsystem: 17de:08a4, board: KWorld/VStream XPert 
>>>> DVB-T [card=14,insmod option]
>>>> TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
>>>>
>>>> cx88[0]: Test OK
>>>>
>>>> input: cx88 IR (KWorld/VStream XPert D as /class/input/input5
>>>> cx88[0]/0: found at 0000:01:08.0, rev: 5, irq: 18, latency: 32, 
>>>> mmio: 0xfb000000
>>>> cx88[0]/0: registered device video1 [v4l2]
>>>> cx88[0]/0: registered device vbi0
>>>> ACPI: PCI Interrupt 0000:01:08.2[A] -> Link [APC3] -> GSI 18 (level, 
>>>> low) -> IRQ 18
>>>> cx88[0]/0: found at 0000:01:08.2, rev: 5, irq: 18, latency: 32, 
>>>> mmio: 0xfa000000
>>>> cx88[0]/0: registered device video2 [v4l2]
>>>> cx88[0]/0: registered device vbi1
>>>>
>>>> cx2388x dvb driver version 0.0.6 loaded
>>>> cx8802_register_driver() ->registering driver type=dvb access=shared
>>>>
>>>> cx2388x dvb driver version 0.0.6 loaded
>>>> cx8802_register_driver() ->registering driver type=dvb access=shared
>>>> cx2388x dvb driver version 0.0.6 loaded
>>>> cx8802_register_driver() ->registering driver type=dvb access=shared
>>>>
>>>>   # lsmod|grep cx8
>>>> cx8800                 54508  0
>>>> cx8802                 36868  0
>>>> cx88xx                 88228  2 cx8800,cx8802
>>>> ir_common              54020  1 cx88xx
>>>> i2c_algo_bit           23428  1 cx88xx
>>>> tveeprom               34832  1 cx88xx
>>>> videodev               45056  3 gspca,cx8800,cx88xx
>>>> compat_ioctl32         25600  1 cx8800
>>>> v4l2_common            36736  4 cx8800,cx88xx,videodev,compat_ioctl32
>>>> video_buf              43524  4 cx8800,cx8802,cx88xx,video_buf_dvb
>>>> btcx_risc              21896  3 cx8800,cx8802,cx88xx
>>>> i2c_core               44032  12 
>>>> it87,i2c_isa,or51132,mt352,cx22702,cx22700,nvidia,cx88xx,i2c_algo_bit,tveeprom,dvb_pll,i2c_nforce2 
>>>>
>>>>
>>>> I moved this card from a x86 box to this 64x2 AM2 box and the 
>>>> following files have the same contents. udev the same as on the x86 
>>>> box. This is definitely a KWorld/VStream XPert DVB-T card which I 
>>>> had working for over one year at least. Kernel is 2.6.22-rc3, same 
>>>> problem with 2.6.22-rc2-git7. I haven't checked it in a few weeks on 
>>>> the x86 box, but it was OK on earlier 2.6.22-rc kernels.
>>>>
>>>> # less /etc/sysconfig/hardware/hwcfg-bus-pci-0000\:01\:08.0
>>>> # YaST configured TV card
>>>> # 75Hn.ANrE4vYza54:CX23880/1/2/3 PCI Video and Audio Decoder
>>>> MODULE='cx88-dvb'
>>>> STARTMODE='auto'
>>>>
>>>> # less /etc/modprobe.d/tv
>>>>
>>>> alias char-major-81 videodev
>>>> options i2c-algo-bit bit_test=1
>>>> # YaST configured TV card
>>>> # 75Hn.ANrE4vYza54:CX23880/1/2/3 PCI Video and Audio Decoder
>>>> alias char-major-81-0 cx8800
>>>> alias char-major-81-1 off
>>>> alias char-major-81-2 off
>>>> alias char-major-81-3 off
>>>>
>>>> I added this to modprobe.conf.local to get the card recognised.
>>>> # less /etc/modprobe.conf.local
>>>> #
>>>> # please add local extensions to this file
>>>> #
>>>> options cx88xx  card=14
>>>>
>>>> from lspci -vvv
>>>> ===============
>>>> 01:08.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI 
>>>> Video and Audio Decoder (rev 05)
>>>>          Subsystem: KWorld Computer Co. Ltd. Unknown device 08a4
>>>>          Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
>>>> ParErr- Stepping- SERR- FastB2B-
>>>>          Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium 
>>>>  >TAbort- <TAbort- <MAbort- >SERR- <PERR+
>>>>          Latency: 32 (5000ns min, 13750ns max), Cache Line Size: 32 
>>>> bytes
>>>>          Interrupt: pin A routed to IRQ 18
>>>>          Region 0: Memory at fb000000 (32-bit, non-prefetchable) 
>>>> [size=16M]
>>>>          Capabilities: [44] Vital Product Data
>>>>          Capabilities: [4c] Power Management version 0
>>>>                  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA 
>>>> PME(D0-,D1-,D2-,D3hot-,D3cold-)
>>>>                  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
>>>>
>>>> 01:08.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and 
>>>> Audio Decoder (rev 05)
>>>>          Subsystem: KWorld Computer Co. Ltd. Unknown device 08a4
>>>>          Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
>>>> ParErr- Stepping- SERR- FastB2B-
>>>>          Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium 
>>>>  >TAbort- <TAbort- <MAbort- >SERR- <PERR+
>>>>          Latency: 32 (1000ns min, 22000ns max), Cache Line Size: 32 
>>>> bytes
>>>>          Interrupt: pin A routed to IRQ 18
>>>>          Region 0: Memory at fa000000 (32-bit, non-prefetchable) 
>>>> [size=16M]
>>>>          Capabilities: [4c] Power Management version 0
>>>>                  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA 
>>>> PME(D0-,D1-,D2-,D3hot-,D3cold-)
>>>>                  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
>>>>
>>>> Any ideas?
>>>> Thanks and Regards
>>>> Sid.
>>>
>>> What happens if you try card=43 instead of card=14?
>>>
>>> You can't expect your card to 'just work' like this -- clearly we 
>>> will have to
>>> add an patch to the driver to autodetect your device, as it does have 
>>> a unique
>>> PCI subsystem ID.
>>>
>>> Let me know what card=43 does, then we can try some other things.
>>>
>>> Good Luck,
>>>
>>> Mike
>>>
>>>
>>>
>> It was being autodected for around 2 years and until quite recently, 
>> on the x86 box. January 20th. and 24th., but not in the following 
>> message log. It doesn't appear in 20070410 or 20070415. Can't figure 
>> out which kernel was in use then as they have been removed, but I 
>> think up to 2.6.21-rc and the earliest I have around is 2007-05-03 
>> 22:04 2.6.21-git4.
>>  # bzcat /var/log/messages-20070403.bz2 |less
>> Jan 20 03:37:45 barrabas kernel: CORE cx88[0]: subsystem: 17de:08a6, 
>> board: KWorld/VStream XPert DVB-T [card=14]
>> Jan 20 03:37:45 barrabas kernel: cx88[0]/2: cx2388x based dvb card
>> Jan 20 03:37:45 barrabas kernel: DVB: registering new adapter (cx88[0]).
>> Jan 20 03:37:45 barrabas kernel: DVB: registering frontend 0 (Zarlink 
>> MT352 DVB-T)...
>> Ditto for 24th. January.
>>
>> I shall try card 43 again on reboot, stuff below didn't work out.
>> # rmmod cx8800
>> # rmmod cx8802
>> # rmmod ir_common
>> ERROR: Module ir_common is in use by cx88xx
>> # rmmod cx88xx
>> # lsmod|grep cx8
>> # modprobe cx88-dvb
>> FATAL: Error inserting cx88_dvb 
>> (/lib/modules/2.6.22-rc3-smp/kernel/drivers/media/video/cx88/cx88-dvb.ko): 
>> No such device
>> tindog:/ftp/May07 # lsmod|grep cx8
>> cx8802                 36868  0
>> cx88xx                 88228  1 cx8802
>> ir_common              54020  1 cx88xx
>> i2c_algo_bit           23428  1 cx88xx
>> tveeprom               34832  1 cx88xx
>> videodev               45056  2 cx88xx,gspca
>> v4l2_common            36736  3 cx88xx,videodev,compat_ioctl32
>> video_buf              43524  3 cx8802,cx88xx,video_buf_dvb
>> btcx_risc              21896  2 cx8802,cx88xx
>> i2c_core               44032  12 
>> cx88xx,it87,i2c_isa,or51132,mt352,cx22702,cx22700,nvidia,i2c_algo_bit,tveeprom,dvb_pll,i2c_nforce2 
>>
>>
>> Regards
>> Sid.
> No luck with card=43 either, kernel 2.6.22-rc3-git5.
> Regards
> Sid.
> 

Sid,

There's no way that this card could have autodetected in an earlier kernel,
unless you had a distro-patched kernel, in which the distro had added support
for your card without syncing with upstream v4l / dvb ...

There simply is no card autodetection entry for 17de:08a6.

Which distro are / were you running, and were you running any special kernel flavor?

-Mike




More information about the linux-dvb mailing list