[linux-dvb] DVICO FusionHDTV DVB-T Nano

Adam Harvey adam at adamharvey.name
Fri Jun 8 20:27:44 CEST 2007


Quoting Michael Krufky <mkrufky at linuxtv.org>:
> This looks like the FX2 usb controller is in an unstable state...    
> First, try a
> cold reboot.  If that doesnt help, then boot into windows and give it a quick
> test, then warm boot back into linux.  If that still doesnt help,   
> please let me
> know.

Well, bad news and slightly less bad news. The bad news: a cold boot  
had the same result. The dmesg output:

[   34.337117] check for warm 1660 932
[   34.337121] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   34.337124] check for cold fe9 d500
[   34.337126] check for warm fe9 d501
[   34.337128] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   34.337131] check for cold fe9 db50
[   34.337132] check for warm fe9 db51
[   34.337134] check for cold fe9 db54
[   34.337136] check for warm fe9 db55
[   34.337138] check for cold fe9 db58
[   34.337140] check for warm fe9 db59
[   34.337141] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   34.337144] check for cold fe9 db00
[   34.337146] check for warm fe9 db01
[   34.337147] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   34.337150] check for cold fe9 db10
[   34.337152] check for warm fe9 db11
[   34.337154] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   34.337156] check for warm fe9 db78
[   34.337158] check for warm fe9 db70
[   34.337160] dvb-usb: found a 'DViCO FusionHDTV DVB-T NANO2' in warm state.
[   34.337173] power control: 1
[   34.337175] >>> de 00
[   34.337178] dvb-usb: bulk message failed: -22 (2/0)
[   34.337235] dvb-usb: will pass the complete MPEG2 transport stream  
to the software demuxer.
[   34.337407] all in all I will use 40960 bytes for streaming
[   34.337409] allocating buffer 0
[   34.337419] buffer 0: ffff81003223a000 (dma: 841195520)
[   34.337421] allocating buffer 1
[   34.337430] buffer 1: ffff810031858000 (dma: 830832640)
[   34.337432] allocating buffer 2
[   34.337439] buffer 2: ffff810031842000 (dma: 830742528)
[   34.337441] allocating buffer 3
[   34.337449] buffer 3: ffff81003229e000 (dma: 841605120)
[   34.337451] allocating buffer 4
[   34.337459] buffer 4: ffff8100325ae000 (dma: 844816384)
[   34.337461] allocation successful
[   34.337467] DVB: registering new adapter (DViCO FusionHDTV DVB-T NANO2)
[   34.338098] >>> 51
[   36.337886] dvb-usb: bulk message failed: -110 (1/0)
[   36.337893] >>> 05 fd 00
[   38.334831] dvb-usb: bulk message failed: -110 (3/0)
[   38.478625] gpio_write failed.
[   38.478627] >>> 05 fd 02
[   40.475720] dvb-usb: bulk message failed: -110 (3/0)
[   40.656584] >>> 09 01 01 0f 7f
[   42.656427] dvb-usb: bulk message failed: -110 (5/0)
[   42.656493] dvb-usb: no frontend was attached by 'DViCO FusionHDTV  
DVB-T NANO2'
[   42.656670] power control: 0
[   42.656672] dvb-usb: DViCO FusionHDTV DVB-T NANO2 successfully  
initialized and connected.
[   42.656688] usbcore: registered new interface driver dvb_usb_cxusb

A warm boot from Windows, however, resulted in success:

[   33.991423] check for warm 1660 932
[   33.991427] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   33.991430] check for cold fe9 d500
[   33.991432] check for warm fe9 d501
[   33.991434] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   33.991436] check for cold fe9 db50
[   33.991438] check for warm fe9 db51
[   33.991440] check for cold fe9 db54
[   33.991442] check for warm fe9 db55
[   33.991443] check for cold fe9 db58
[   33.991445] check for warm fe9 db59
[   33.991447] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   33.991450] check for cold fe9 db00
[   33.991451] check for warm fe9 db01
[   33.991453] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   33.991456] check for cold fe9 db10
[   33.991457] check for warm fe9 db11
[   33.991459] something went very wrong, device was not found in  
current device list - let's see what comes next.
[   33.991462] check for warm fe9 db78
[   33.991463] check for warm fe9 db70
[   33.991466] dvb-usb: found a 'DViCO FusionHDTV DVB-T NANO2' in warm state.
[   33.991483] power control: 1
[   33.991486] >>> de 00
[   33.991621] dvb-usb: will pass the complete MPEG2 transport stream  
to the software demuxer.
[   34.022650] all in all I will use 40960 bytes for streaming
[   34.022655] allocating buffer 0
[   34.022667] buffer 0: ffff810032ece000 (dma: 854384640)
[   34.022669] allocating buffer 1
[   34.022678] buffer 1: ffff810032ee2000 (dma: 854466560)
[   34.022680] allocating buffer 2
[   34.022689] buffer 2: ffff81003241a000 (dma: 843161600)
[   34.022691] allocating buffer 3
[   34.022700] buffer 3: ffff810032f60000 (dma: 854982656)
[   34.022702] allocating buffer 4
[   34.022710] buffer 4: ffff81003626a000 (dma: 908500992)
[   34.022712] allocation successful
[   34.022718] DVB: registering new adapter (DViCO FusionHDTV DVB-T NANO2)
[   34.023541] >>> 51
[   34.023663] >>> 05 fd 00
[   34.023888] <<< d9
[   34.343458] >>> 05 fd 02
[   34.344561] <<< db
[   34.624077] <<< 01 14
[   34.624083] DVB: registering frontend 0 (Zarlink ZL10353 DVB-T)...
[   34.636468]  ok
[   34.637412] input: bttv IR (card=34) as /class/input/input5
[   34.700797] power control: 0
[   34.700803] dvb-usb: DViCO FusionHDTV DVB-T NANO2 successfully  
initialized and connected.
[   34.700822] usbcore: registered new interface driver dvb_usb_cxusb

The problem now is that nothing seems to be able to tune in a channel.  
(If this is off-topic here, please let me know.) The antenna  
connection is fine, since it works in Windows, and I have a correct  
channels.conf file for my area, but something's still not quite right.  
Scan output:

adam at lawngnome:/tmp$ scan  
/usr/share/doc/dvb-utils/examples/scan/dvb-t/au-Perth
scanning /usr/share/doc/dvb-utils/examples/scan/dvb-t/au-Perth
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 226500000 1 3 9 3 1 1 0
initial transponder 177500000 1 2 9 3 1 2 0
initial transponder 191625000 1 3 9 3 1 1 0
initial transponder 219500000 1 3 9 3 1 1 0
initial transponder 536625000 1 2 9 3 1 2 0
>>> tune to:  
>>> 226500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_16:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 226500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_16:HIERARCHY_NONE (tuning  
>>> failed)
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 177500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 177500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE (tuning  
>>> failed)
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 191625000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_16:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 191625000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_16:HIERARCHY_NONE (tuning  
>>> failed)
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 219500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_16:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 219500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_16:HIERARCHY_NONE (tuning  
>>> failed)
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 536625000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to:  
>>> 536625000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE (tuning  
>>> failed)
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)
Done.


Running tzap shows:

adam at lawngnome:/tmp$ tzap -c ~/.mplayer/channels.conf "7 Digital" -r
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 177500000 Hz
video pid 0x0301, audio pid 0x0302
status 00 | signal 0000 | snr 0000 | ber 00000000 | unc 00000000 |
status 00 | signal 0000 | snr 0000 | ber 00000000 | unc 00000000 |
status 00 | signal 0000 | snr 0000 | ber 00000000 | unc 00000000 |
status 00 | signal 0000 | snr 0000 | ber 00000000 | unc 00000000 |
status 00 | signal 0000 | snr 0000 | ber 00000000 | unc 00000000 |
status 00 | signal 0000 | snr 0000 | ber 00000000 | unc 00000000 |

And so on. MPlayer seems to have the same issue.

> BTW, Markus emailed you asking you to try his repository -- this   
> problem here is
> with the usb controller, so trying his repository will not help you.

I did try Markus's repository just for the sake of completeness, but  
the results are the same.

Thanks,

Adam



More information about the linux-dvb mailing list