[linux-dvb] Vivanco 21056/LR306 a.k.a. MSI DVB at Anywhere a.k.a LifeView Hybrid doesn't scan

Werner Braun werner.braun at gmx.de
Thu Jun 14 22:31:46 CEST 2007


>> 
>> I've tried quite a few things before bothering you here, I even stripped 
>>the 
>> firmware out of the driver on the Vivanco web side instead of using 
>> TDA10046Lifeview, but no avail, so I'm somewhat clueless at the moment and 
>> hoping that somebody here can help me out.
>> 

>Hi,

>Werner, did you try with card=112?

>You are missing the i2c_gate functionality for tuning.

>Cheers,
>Hermann

Hermann, 

thanks for your reply. Here's what DMESG says when using card=112:


saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:02:0e.0, rev: 208, irq: 18, latency: 32, mmio: 
0xdd800000
saa7133[0]: subsystem: 4e42:3306, board: ASUSTeK P7131 Hybrid [card=112,insmod 
option]
saa7133[0]: board init: gpio is 210000
input: saa7134 IR (ASUSTeK P7131 Hybri as /class/input/input7
saa7133[0]: i2c eeprom 00: 42 4e 06 33 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 00 62 08 ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 ff 01 ed ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 05 01 01 16 32 15 ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 1-004b: chip found @ 0x96 (saa7133[0])
tuner 0x4b: Configuration acknowledged
tuner 1-004b: setting tuner address to 61
tuner 1-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: trying to boot from eeprom
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: found firmware revision 29 -- ok

... and now W_SCAN:

tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision ff -- invalid
tda1004x: trying to boot from eeprom
tda1004x: found firmware revision ff -- invalid
tda1004x: waiting for firmware upload...
tda1004x: Error during firmware upload
tda1004x: found firmware revision ff -- invalid
tda1004x: firmware upload failed
saa7133[0]/dvb: could not access tda8290 I2C gate
saa7133[0]/dvb: could not access tda8290 at addr: 0x96
saa7133[0]/dvb: could not access tda8290 I2C gate
tda827xa_set_params: could not write to tuner at addr: 0xc2
saa7133[0]/dvb: could not access tda8290 I2C gate
saa7133[0]/dvb: could not access tda8290 at addr: 0x96
saa7133[0]/dvb: could not access tda8290 I2C gate

Note, that I am using the same FW file as the last time. Any further clue on 
behalf of yours? Could you elaborate on the i2c_gate thing?

TIA & best regards
Werner



More information about the linux-dvb mailing list