[linux-dvb] Vivanco 21056/LR306 a.k.a. MSI DVB at Anywhere a.k.a LifeView Hybrid doesn't scan

Werner Braun werner.braun at gmx.de
Tue Jun 19 02:01:36 CEST 2007


Hartmut,

>Summing up the test results, i have the impression that this card is 
different
>from what we have yet.
>I am almost sure that the problem lies in the GPIO configuration. Please try 
>the
>following:
>Please keep forcing the card type to 94
>In the configuration structure (saa7134-dvb.c):
>static struct tda1004x_config ads_tech_duo_config = {
>change the entry
>.gpio_config   = TDA10046_GP00_I,
>to
>.gpio_config   = TDA10046_GP10,
>I expect that this makes DVB-T work but it might break analog TV.
>Please try also
>.gpio_config   = TDA10046_GP10_I,
>This should make analog work again but it might carsh the channel decoder
>(bad firmware) if this is the case, please report this. It might be necessary 
>to
>increase a delay in the channel decoder initialization procedure.

applied your patches and - guess what - it worked. Even sound worked 
spontaneously. This is brilliant, thanks a lot. Analog didn't work apart from 
channel E12 (FAB - Fernsehen aus Berlin). In DVB-T, I haven't been able to 
tune in into all stations (e.g. RTL, ZDF), but this might be an antenna 
issue.

I will also apply Hermann's patch for the autodetection thing, then there's 
another card in the database.

Do you need any further card-related informations? Photos, whatsoever?

Thanks again for this great support.

Best regards
Werner



More information about the linux-dvb mailing list