[linux-dvb] TT S-1401 Error: A frontend driver was not found for device 1131/7146 subsystem 13c2/1018

Oliver Endriss o.endriss at gmx.de
Sat Jun 30 01:47:29 CEST 2007


Sebastian wrote:
> Hello,
> 
> i recently bought a Technotrend S-1401 DVB-S card. Somehow this card
> wont work for me, because i dont get a frontend0 device. Other device
> nodes like demux0 or dvr0 are there, but frontend0 is missing. I am
> using Linux 2.6.20-16 (2.6.21 tested too) and the latest Mercurial DVB
> drivers. I get the following kernel messages with debug=1 in tda10086.c
> 
> [   34.452456] saa7146: register extension 'budget dvb'.
> [   34.452508] ACPI: PCI Interrupt 0000:02:08.0[A] -> GSI 20 (level,
> low) -> IRQ 22
> [   34.452535] saa7146: found saa7146 @ mem f8982000 (revision 1, irq
> 22) (0x13c2,0x1018).
> [   34.452541] saa7146 (0): dma buffer size 192512
> [   34.452543] DVB: registering new adapter (TT-Budget-S-1401 PCI)
> [   34.490315] adapter has MAC addr = 00:d0:5c:09:11:8e
> [   34.552672] tda10086: tda10086_attach
> [   34.552754] tda10086: tda10086_read_byte: error reg=0x1e, ret=-121
> [   34.552774] budget: A frontend driver was not found for device
> 1131/7146 subsystem 13c2/1018
> 
> function tda10086_attach expects tda10086_read_byte to return 0xe1, but
> it returns -121 instead.
> 
> Since its very hard for me to understand this driver code, this is all i
> could find out till now. Does anybody have a clue what the problem is or
> how to fix it?

Basically the driver should work. Are you sure that the card is ok,
i.e. did you test the card with the windoes driver?

Oliver

-- 
----------------------------------------------------------------
VDR Remote Plugin 0.3.9: http://www.escape-edv.de/endriss/vdr/
----------------------------------------------------------------




More information about the linux-dvb mailing list