[linux-dvb] HVR4000 status

Steven Toth stoth at hauppauge.com
Wed Mar 21 20:35:06 CET 2007


will wrote:
>> I am also playing with that repo and am able to get a picture so something
>> is amiss here. I can't assume what it is but please try using szap
>> and mplayer to diagnose if there is a problem rather than using other
>> tools.
>>
>>     
>
> I gave it a go using szap and mplayer still the same results I'm afraid.
> I've listed a sample of the results below.
>
> sh-3.00$ szap 'BBC News 24'
> reading channels from file '/home/htpc/.szap/channels.conf'
> zapping to 3 'BBC NEWS 24':
> sat 0, frequency = 10773 MHz H, symbolrate 22000000, vpid = 0x1518, apid =
> 0x1519 sid = 0x18a0
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> FE_DISEQC_SEND_MASTER_CMD failed: Invalid argument
> FE_DISEQC_SEND_BURST failed: Operation not supported
> status 1f | signal 0074 | snr 0000 | ber 00000000 | unc 00000000 |
> FE_HAS_LOCK
> status 1f | signal 0074 | snr 0000 | ber 00000000 | unc 00000000 |
> FE_HAS_LOCK
> status 1f | signal 0074 | snr 0000 | ber 00000000 | unc 00000000 |
> FE_HAS_LOCK
> status 1f | signal 0074 | snr 0000 | ber 00000000 | unc 00000000 |
> FE_HAS_LOCK
>   

It looks like the hardware is tuned and probably streaming correctly (1f 
is a very good indicator for this product). Don't trust the snr or ber 
values, they're not implemented.

<cut>

Other people have reported at least some success, this really sounds 
like a local configuration issue, especially when the hardware state 
looks good. Do you have the correct pid values in the config file?

Does 'dvbtraffic' show valid pid data?

Don't forget the -r arg to szap.

Steve




More information about the linux-dvb mailing list