[linux-dvb] CAM inserted/used reduces signal and SNR ?

P. van Gaans w3ird_n3rd at gmx.net
Mon Nov 19 21:19:27 CET 2007


On 11/18/2007 10:34 AM, Luc Brosens wrote:
> Hi,
> 
> side note :
> the problems in my previous post "KNC1 TV-Station S, revision 0x1894, doesn't tune", were related to the PCI-slots of the motherboard I used
> rebuilt the machine around a new motherboard, both KNC1's are now recognized and able to tune
> lesson learnt : check the hardware before complaining about the software ...
> 
> next step is accessing the scrambled signals
> 
> as I said, the cards scan OK and using "szap" I can tune to them :
> mythtv at silverstar:~> szap -a 1 -c channels.conf VT4
> reading channels from file 'channels.conf'
> zapping to 795 'VT4':
> sat 0, frequency = 12669 MHz V, symbolrate 22000000, vpid = 0x03af, apid = 0x039b sid = 0x31e5
> using '/dev/dvb/adapter1/frontend0' and '/dev/dvb/adapter1/demux0'
> status 05 | signal 9ffb | snr 21f6 | ber 0000ea08 | unc 00000000 |
> status 1f | signal d430 | snr dad3 | ber 00000100 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d47e | snr dab5 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d5b8 | snr dacd | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d458 | snr dac7 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d5bc | snr daf7 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d460 | snr da9a | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d47c | snr daac | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d46c | snr dac1 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d465 | snr dabe | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d481 | snr dabb | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d46f | snr dab5 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d43b | snr daa0 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d468 | snr dabe | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d47e | snr daa6 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d342 | snr dac1 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> 
> mythtv at silverstar:~> szap -a 1 -c channels.conf VTM
> reading channels from file 'channels.conf'
> zapping to 793 'VTM':
> sat 0, frequency = 12669 MHz V, symbolrate 22000000, vpid = 0x03ad, apid = 0x0399 sid = 0x31e3
> using '/dev/dvb/adapter1/frontend0' and '/dev/dvb/adapter1/demux0'
> status 1f | signal d404 | snr b772 | ber 0000c000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d479 | snr da8b | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d5b7 | snr daac | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d5b6 | snr da97 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d47c | snr daa0 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d5bb | snr da70 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d342 | snr da97 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d480 | snr daa6 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d340 | snr da97 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d481 | snr da40 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d47e | snr da6a | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d340 | snr da6d | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> status 1f | signal d468 | snr da91 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
> 
> both VTM and VT4 are encrypted channels here, so no mpg-output at this time
> 
> I have found one (1) encrypted channel that works using gnutv :
> 
> mythtv at silverstar:~> gnutv -adapter 1 -channels channels.conf -out dvr VTM
> Using frontend "ST STV0299 DVB-S", type DVB-S
> status SCVYL | signal d47c | snr dac1 | ber 0000ff00 | unc 00000000 | FE_HAS_LOCK
> CAM Application type: 01
> CAM Application manufacturer: 0100
> CAM Manufacturer code: 0000
> CAM Menu string: CANALDIGITAAL
> CAM supports the following ca system ids:
>   0x0100
> Received new PMT - sending to CAM...
> mythtv at silverstar:~>
> 
> using mplayer, I have a clear picture
> this proves to me that descrambling works
> 
> but I have yet to find another channel that works, even on the same transponder frequency none of the others work !?
> 
> what's more, it looks like it's the CAM that's the cause of things :
> 
> first, remove the CAM from the CI slot :
> 
> mythtv at silverstar:~> gnutv -adapter 1 -channels channels.conf -out dvr VT4
> Using frontend "ST STV0299 DVB-S", type DVB-S
> status SCVYL | signal d464 | snr da9a | ber 0000a700 | unc 00000000 | FE_HAS_LOCK
> 
> the lock is immediate
> 
> insert the CAM, same command :
> 
> mythtv at silverstar:~> gnutv -adapter 1 -channels channels.conf -out dvr VT4
> Using frontend "ST STV0299 DVB-S", type DVB-S
> CAM Application type: 0140 | snr 83c1 | ber 0000ff00 | unc 00000000 |
> CAM Application manufacturer: 0100
> CAM Manufacturer code: 0000
> CAM Menu string: CANALDIGITAAL
> CAM supports the following ca system ids:er 0000ff00 | unc 00000000 |
>   0x0100
> mythtv at silverstar:~>  c82e | snr a15e | ber 0000ff40 | unc 00000000 |
> 
> so gnutv accesses the CAM, and the signal and SNR drop to unusable levels ?
> 
> the same happens for unencrypted channels : the signal and SNR drop if a CAM is present and gnutv is used
> 
> NO CAM :
> mythtv at silverstar:~> gnutv -adapter 1 -channels channels.conf "BBC World"
> Cannot open decoder; defaulting to dvr output
> Using frontend "ST STV0299 DVB-S", type DVB-S
> status SCVYL | signal ccf4 | snr d6b6 | ber 0000ff00 | unc 00000000 | FE_HAS_LOCK
> 
> INSERT CAM :
> mythtv at silverstar:~> gnutv -adapter 1 -channels channels.conf "BBC World"
> Cannot open decoder; defaulting to dvr output
> Using frontend "ST STV0299 DVB-S", type DVB-S
> CAM Application type: 0156 | snr 81ed | ber 0000ff00 | unc 00000000 |
> CAM Application manufacturer: 0100
> CAM Manufacturer code: 0000
> CAM Menu string: CANALDIGITAAL
> CAM supports the following ca system ids:er 0000ff38 | unc 00000000 |
>   0x0100
> mythtv at silverstar:~>  bcc0 | snr a05f | ber 0000ff18 | unc 00000000 |
> 
> 
> szap is not bothered by the presence of a CAM (because it doesn't access it ?), tuning works fine with and without one
> 
> questions :
> 
> why does inserting and accessing a CAM reduce the signal and SNR levels ? (even if no descrambling is needed, as for BBC World)
> how can this be solved ?
> anyone out there having the same problems ?
> 
> thanks,
> 
> Luc
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 

Which motherboard do you have? And you've got a clean picture without 
blocks with the offical Dutch/Flemish Mediaguard CAM? You would be the 
first. (see http://linuxtv.org/wiki/index.php/KNC1_TV-Station_DVB-S )

Can you reproduce the descrambling, are you sure VTM was not temporarily 
unscrambled?

P.



More information about the linux-dvb mailing list