[linux-dvb] AF9015 Driver (USB)

Rafael Antoniello rafael.antoniello at gmail.com
Thu Nov 22 11:42:21 CET 2007


Hi.
I finally get your driver working very well with my usb-tdt-stick.
So you can add to the HW-supported list the BestBuy Easy TV USB Stick 
(AF9015 + MT2061).
If someone is interested, I am running it on an 2.6.9 kernel (minimal 
changes are to be added to compile v4l with these drivers).
Now I am trying to embed these drivers on a ARM7 at 300MHz based system, 
without success yet. It seems that performance has something to do in 
this reduced environment (not actually sure). If someone is interested 
or has experience in this task, suggestions are welcome.
Please continue reporting new releases for the drivers (I will). Thank 
you very much Antti and Manu.
Cheers,
Rafael.

Antti Palosaari escribió:
> morjens
> I put my version also online if there is someone who wants to play 
> with it. Many Finnish people have reported it working very well with 
> A-Link DTU(m) and Fujitech stick. No any success reports outside 
> Finland still...
> Latest firmware, version 4.95.0, and the driver patch can be found 
> from link below.
> http://otit.fi/~crope/v4l-dvb/af9015/
>
> regards
> Antti
>
> Manu Abraham wrote:
>> Hi,
>>
>> I saw your post on the ML also, rather than replying to both, will 
>> just add CC to the list.
>>
>> Lindsay Mathieson wrote:
>>> Hi Manu, I was trying the af9015 driver you're working on at
>>> http://jusst.de/hg/af901x/summary but not having much success - I
>>> suspect i have the wrong firmware (got it from
>>> http://www.mail-archive.com/linux-dvb@linuxtv.org/msg21157.html).
>>>
>>> Would you be able to send it to me?
>>
>> The firmwares are here: http://jusst.de/manu/fw/AFA/
>> The reference fw, uses the newer version, 0x447000 instead of 0x441000
>> But i don't think there exists a large difference except for some 
>> refinements
>>  
>>> I'm using a DigitalNow TinyTwin USB dual tuner
>>
>> The maxlinear devices are not supported atm, waiting for some 
>> complications
>> to be flushed out from the af901x tree.
>>
>> I guess most probably you have the Twin maxlinear device based ones.
>> Can you please do a lsusb and check the vendor and product ID's ?
>>
>> if you add in your vendor and product id's, most probably loading the 
>> af901x
>> module, it will tell you about your hardware configuration.
>>
>>> Thanks - Lindsay
>>>
>>
>> Regards,
>> Manu
>>
>




More information about the linux-dvb mailing list