[linux-dvb] CAM inserted/used reduces signal and SNR ?

Luc Brosens dvb at bsc-bvba.be
Thu Nov 29 18:52:46 CET 2007



Manu Abraham wrote:
> Luc Brosens wrote:
>> Manu Abraham wrote:
>>> Luc Brosens wrote:
>>>
>>>> Manu,
>>>>
>>>> your guess is correct, under W2K no tuning problems. The scrambled channels tune in an instance, now and then there are some artifacts though. But
>>>> tuning works !
>>>>
>>>> so my hardware setup works, now how to find that 'tenderness' in the driver ? You think that the tuning-part of the drivers (that would be the
>>>> STV0299-stuff wouldn't it ?)
>>> It can be the STV0299 + the tuner on it. What tuner do you have on the card ? Maybe 
>>> it is bad tuner programming, before looking elsewhere. Tuners wrongly programmed 
>>> cause such weird issues, one can say.
>>>
>>>> if somebody can set me off in the right direction, I'll get it solved
>>>>
>>>> the Windows TV-viewer that came with the cards reports a signal of 95%, even for scrambled channels : another indication that tuning could be done a
>>>> bit better ?
>>>>
>>>> Luc
>>>>
>>> Manu
>>>
>> Manu,
>>
>> it's a KNCOne TV-Station DVB-S
>> on it, I can see a STV02998 and a SAA7146AH
>> the tuner chip is obscured by a cover plate
>> I've prepared a little page with some pictures and the dmesg, lsmod and lspci info :
>>
>> http://www.bsc-bvba.be/persoonlijk/kncone.html
>>
>> even though I bought it as a TV-Station, and that's what it says on the box, it is taken to be a TV-Star
>> if I change the PCI-id-table in budget_av.c and make it a TV-Station (SUBID_DVBS_KNC1), I get "timeout waiting for end of xfer" from the SAA
>>
> 
> You are trying the latest changes in the tree, ie the topmost changes, 
> IIRC Oliver had some fixes which fixed some IRQ issues.
> 
>> the budget-av coding for the TV-Star seems to suggest the tuner is a SD1878, which is confirmed by the label on the cover plate (you can read it on
>> the pictures of the front of the card)
>>
>> I'll go and read the SD1878 coding ...
> 
> try this change:
> 
> in dvb-pll.c: http://linuxtv.org/hg/v4l-dvb/file/85f583ec85d6/linux/drivers/media/dvb/frontends/dvb-pll.c
> 
> The following lines:
> 
>       473 		{ 1250000, 500, 0xc4, 0x00},
>       474 		{ 1550000, 500, 0xc4, 0x40},
>       475 		{ 2050000, 500, 0xc4, 0x80},
>       476 		{ 2150000, 500, 0xc4, 0xc0},
> 
> 
> change this to make it look like this:
> 
> { 1250000, 500, 0xc4, 0xc0},
> { 1450000, 500, 0xc4, 0xc0},
> { 2050000, 500, 0xc4, 0xc0},
> { 2150000, 500, 0xc4, 0xc0},
> 
> This is bad but, check whether you see any difference.
> 
> Manu
> 
Manu,

there's a definite improvement in tuning : almost all tuning attempts succeed now, scrambled and all
and it's a rainy evening, which reduces reception a bit

now to re-install mplayer/MythTV to check out the picture

thanks !

Luc



More information about the linux-dvb mailing list