[linux-dvb] Compro Videomate S350 card

O&M Ugarcina mo.ucina at gmail.com
Fri Oct 12 12:16:56 CEST 2007


O&M Ugarcina wrote:
> Hello Guys,
>
> I just purchased a Compro Videomate S350 satellite card with the 
> intention of using it in mythtv . After installing the card I was 
> surprised to find that it was not being recognized . This is the out 
> put of my dmesg :
>
> saa7130[0]: found at 0000:04:01.0, rev: 1, irq: 21, latency: 64, mmio: 
> 0xfeaffc00
> saa7130[0]: subsystem: 185b:c900, board: UNKNOWN/GENERIC
>   

This (according to the subsystem ID) looks like a clone of Compro 
VideoMate DVB-T300, which should be autodetected in recent kernels. 
Could you please try retesting with linux-2.6.23?

-- 

Hello Alexander,

I just tried it with kernel :
[root at localhost mythtv]# uname -r
2.6.23-5.fc8

dmesg looks like this :

saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 22 (level, low) -> IRQ 21
saa7130[0]: found at 0000:04:01.0, rev: 1, irq: 21, latency: 64, mmio: 
0xfeaffc00
saa7130[0]: subsystem: 185b:c900, board: UNKNOWN/GENERIC 
[card=0,autodetected]
saa7130[0]: board init: gpio is 843f00
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
saa7130[0]: i2c eeprom 00: 5b 18 00 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7130[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 20: 01 40 01 02 02 01 03 01 08 ff 00 87 ff ff ff ff
saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 40: ff d6 00 c0 86 1c 02 01 02 ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
saa7130[0]: i2c eeprom 60: 30 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 70: 00 00 00 10 03 9c ff ff ff ff ff ff ff ff ff ff
saa7130[0]: registered device video0 [v4l2]
saa7130[0]: registered device vbi0

Much thanks for your reply

Milorad


Alexander E. Patrakov
Alexander E. Patrakov wrote:
> O&M Ugarcina wrote:
>> [root at localhost mythtv]# uname -r
>> 2.6.23-5.fc8
>> saa7130[0]: subsystem: 185b:c900, board: UNKNOWN/GENERIC 
>> [card=0,autodetected]
>
> This simply can't be true. 185b:c900 is a T-300, not an unknown board. 
> See 
> http://www.linuxtv.org/hg/v4l-dvb/file/7dba1f554c4a/linux/Documentation/video4linux/CARDLIST.saa7134 
>
>
> Try creating the file /etc/modprobe.d/compro with the following line 
> in it:
>
> options saa7134 card=70
>
> and rebooting.
>
Hello Alexander,
I have implemented the above config and we have progressed a bit further .
This is again with kernel :
[root at localhost mythtv]# uname -r
2.6.23-5.fc8

my dmesg is now a little better and looks like :

Linux video capture interface: v2.00
PCI: Enabling device 0000:00:1f.3 (0001 -> 0003)
ACPI: PCI Interrupt 0000:00:1f.3[C] -> GSI 18 (level, low) -> IRQ 20
saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 22 (level, low) -> IRQ 21
saa7130[0]: found at 0000:04:01.0, rev: 1, irq: 21, latency: 64, mmio: 
0xfeaffc00
saa7130[0]: subsystem: 185b:c900, board: Compro Videomate DVB-T300 
[card=70,insmod option]
saa7130[0]: board init: gpio is 843f00
input: saa7134 IR (Compro Videomate DV as /class/input/input4
sd 0:0:0:0: Attached scsi generic sg0 type 0
sr 2:0:0:0: Attached scsi generic sg1 type 5
sd 4:0:0:0: Attached scsi generic sg2 type 0
sd 4:0:0:1: Attached scsi generic sg3 type 0
sd 4:0:0:2: Attached scsi generic sg4 type 0
sd 4:0:0:3: Attached scsi generic sg5 type 0
cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
cx2388x v4l2 driver version 0.0.6 loaded
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
saa7130[0]: i2c eeprom 00: 5b 18 00 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7130[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 20: 01 40 01 02 02 01 03 01 08 ff 00 87 ff ff ff ff
saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 40: ff d6 00 c0 86 1c 02 01 02 ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
saa7130[0]: i2c eeprom 60: 30 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 70: 00 00 00 10 03 9c ff ff ff ff ff ff ff ff ff ff
tuner 1-0068: chip found @ 0xd0 (saa7130[0])
saa7130[0]: registered device video0 [v4l2]
saa7130[0]: registered device vbi0
CORE cx88[0]: subsystem: 18ac:db10, board: DViCO FusionHDTV DVB-T Plus 
[card=21,autodetected]
TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
saa7130[0]/dvb: frontend initialization failed


Please ignore the references to cx88 as this is coming from my Dvico 
fusion DVBT card which is working perfectly .

So it looks like most of T300's config is usable for my card ( a S350 , 
s-for satellite) except the frontend which I guess needs to be satellite 
specific for LNB control as well as diseqc functionality .

Where do we go from here ?

Best Regards

Milorad






More information about the linux-dvb mailing list