[linux-dvb] Hauppauge Nova-HD-S2

Steven Toth stoth at hauppauge.com
Sat Sep 1 16:25:50 CEST 2007


Richard and Monica Bland wrote:
> All,
>
> I've started trying to get the above working and have hit a wall (not
> literally).
>
> My current setup has a Nova-T and a WinTV34xx installed and working with
> the S2 being a new addition.
>
> I have downloaded and compiled and installed the drivers from here:
>
> http://linuxtv.org/hg/~stoth/hvr4000/
>
> And, on a reboot, my dmesg looks like this:
>
> saa7146: register extension 'budget dvb'.
> saa7146: found saa7146 @ mem f098e000 (revision 1, irq 11) (0x13c2,0x1005).
> saa7146 (0): dma buffer size 192512
> DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
> adapter has MAC addr = 00:d0:5c:20:2e:c5
> DVB: registering frontend 0 (LSI L64781 DVB-T)...
> Linux video capture interface: v2.00
> cx2388x v4l2 driver version 0.0.6 loaded
> CORE cx88[0]: subsystem: 0070:3401, board: Hauppauge WinTV 34xxx models
> [card=1,autodetected]
> TV tuner -1 at 0x1fe, Radio tuner -1 at 0x1fe
> tveeprom 3-0050: Hauppauge model 34705, rev E111, serial# 6197767
> tveeprom 3-0050: tuner model is Philips FI1246 MK2 (idx 11, type 1)
> tveeprom 3-0050: TV standards PAL(I) (eeprom 0x10)
> tveeprom 3-0050: audio processor is CX881 (idx 31)
> tveeprom 3-0050: has radio
> cx88[0]: warning: unknown hauppauge model #34705
> cx88[0]: hauppauge eeprom: model=34705
> input: cx88 IR (Hauppauge WinTV 34xxx  as /class/input/input4
> cx88[0]/0: found at 0000:02:07.0, rev: 3, irq: 10, latency: 32, mmio:
> 0xd2000000
> cx88[0]/0: registered device video0 [v4l2]
> cx88[0]/0: registered device vbi0
> cx88[0]/0: registered device radio0
> CORE cx88[1]: subsystem: 0070:6906, board: Hauppauge WinTV-HVR4000(Lite)
> DVB-S/S2 [card=58,autodetected]
> TV tuner -1 at 0x1fe, Radio tuner -1 at 0x1fe
> tveeprom 4-0050: Hauppauge model 69100, rev B2C3, serial# 2650487
> tveeprom 4-0050: MAC address is 00-0D-FE-28-71-77
> tveeprom 4-0050: tuner model is Conexant CX24118A (idx 123, type 4)
> tveeprom 4-0050: TV standards ATSC/DVB Digital (eeprom 0x80)
> tveeprom 4-0050: audio processor is None (idx 0)
> tveeprom 4-0050: decoder processor is CX882 (idx 25)
> tveeprom 4-0050: has no radio, has IR receiver, has no IR transmitter
> cx88[1]: hauppauge eeprom: model=69100
> input: cx88 IR (Hauppauge WinTV-HVR400 as /class/input/input5
> cx88[1]/0: found at 0000:02:08.0, rev: 5, irq: 5, latency: 32, mmio:
> 0xd4000000
> cx88[1]/0: registered device video1 [v4l2]
> cx88[1]/0: registered device vbi1
>
> It looks like the card is being detected and I'm getting a
> /dev/v4l/video1 device (unexpected), but no additional dvb device in
> /dev/dvb - just the Nova-T's adapter0
>
> Kernel is 2.6.22-gentoo-r5. lsmod is:
>
> snd_pcm_oss            35232  1
> snd_mixer_oss          15744  1 snd_pcm_oss
> snd_seq_oss            29568  0
> snd_seq_midi_event      7936  1 snd_seq_oss
> snd_seq                38320  4 snd_seq_oss,snd_seq_midi_event
> snd_usb_audio          52064  1
> snd_usb_lib            13952  1 snd_usb_audio
> snd_rawmidi            17440  1 snd_usb_lib
> snd_seq_device          8328  2 snd_seq_oss,snd_rawmidi
> snd_hwdep               9220  1 snd_usb_audio
> snd_hda_intel         203032  1
> snd_pcm                51844  3 snd_pcm_oss,snd_usb_audio,snd_hda_intel
> snd_timer              17156  2 snd_seq,snd_pcm
> snd                    34020  14
> snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_seq,snd_usb_audio,snd_usb_lib,snd_rawmidi,snd_seq_device,snd_hwdep,snd_hda_intel,snd_pcm,snd_timer
> snd_page_alloc          9736  2 snd_hda_intel,snd_pcm
> cx8800                 29064  1
> cx88xx                 62244  1 cx8800
> ir_common              33284  1 cx88xx
> i2c_algo_bit            9092  1 cx88xx
> video_buf              22276  2 cx8800,cx88xx
> tveeprom               17424  1 cx88xx
> videodev               28032  3 cx8800,cx88xx
> v4l1_compat            15620  1 videodev
> compat_ioctl32          5120  1 cx8800
> v4l2_common            18432  3 cx8800,cx88xx,videodev
> btcx_risc               7688  2 cx8800,cx88xx
> budget                 14084  1
> budget_core            11908  1 budget
> saa7146                17928  2 budget,budget_core
> ttpci_eeprom            6016  1 budget_core
> dvb_core               73768  2 budget,budget_core
> l64781                  9988  1
> kvm_intel              19340  0
> kvm                    54832  1 kvm_intel
> lirc_mceusb2           13060  1
> lirc_dev               14452  1 lirc_mceusb2
> nvidia               7240340  76
>
> I've looked at the ML archives and the Wiki, but can't find any hints
> there - do I need firmware?
>
>   
Try loading the cx88-dvb module then search the ML for the firmware 
details, although they might even be on the wiki by now.

- Steve



More information about the linux-dvb mailing list