[linux-dvb] New Card: Compro VideoMate S300/S350 DVB-S

Jan Louw myvonkpos at mweb.co.za
Mon Sep 3 10:53:45 CEST 2007


Hi Richard,

When you determine which frontend your card has, check if the frontend 
module is available and loaded with the 'lsmod' command. The saa7134 
module is only responsible for controlling the saa713x family of 
multimedia PCI bridges, not the frontend chip. Additionally, what 
confuses me is that the saa7134-dvb module has a dependency of 'mt352', 
which might be correct for your card (its a DVB-T demod), but certainly 
isn't  correct for my DVB-S card.

We need someone more knowledgeable to fill in the blanks for us both :-)

Regards
JD

richard (MQ) wrote:
> Hi Jan,
>
> Yes, I bought it because it was listed at linuxtv.org
> (http://www.linuxtv.org/wiki/index.php/DVB-T_PCI_Cards) and surprised /
> disappointed that it doesn't go. It's likely something I'm doing wrong,
> maybe the same applies to you (since the message is exactly the same)?
>
> The OpenSuSE config tool 'YaST' sees it and thinks it's OK but doesn't
> find any stations. When I look in the logs I see this message "frontend
> initialization failed", same when I rmmod it and reload by hand.
>
> I'm at work right now so can't look at teh board to see which
> demodulator, I'll do so tonight and report back. BTW though this is a
> DVB-T card, not DVB-S.
>
> Cheers
> Richard (MQ)
>
> Jan D. Louw wrote:
>   
>> Hi Richard,
>>
>> Strange, the Compro VideoMate T200 is listed as a saa7134 supported card 
>> (cards #70 or #71 I think). Just for interest sake, do you know which 
>> demodulator chip the T200 uses? I'd like to compare this with the 
>> ZL10313 used by the S300.
>>
>> BTW, I did my S300 tests with Mandriva 2007.1 x86_64, with kernel 
>> 2.6.17-14mdvcustom
>>
>> Regards
>> JD
>>
>>
>> Richard (MQ) wrote:
>>     
>>> Hi List,
>>>
>>>       
>>>> What is needed to add support for the Compro VideoMate S300/S350 DVB-S 
>>>> budget card?
>>>>
>>>> Below is the output of 'lspci -v -nn':
>>>>
>>>> 07:00.0 Multimedia controller [0480]: Philips Semiconductors SAA7130 
>>>> Video Broadcast Decoder [1131:7130] (rev 01)
>>>>         Subsystem: Compro Technology, Inc. Unknown device [185b:c900]
>>>>         Flags: bus master, medium devsel, latency 32, IRQ 66
>>>>         Memory at 51104800 (32-bit, non-prefetchable) [size=1K]
>>>>         Capabilities: [40] Power Management version 1
>>>>
>>>> The card is uses the Philips SAA7130 PCI bridge with a ZL10313
>>>> demodulator/frontend chip, which the DVB wiki says is closely related to 
>>>> the mt312 demodulator.
>>>>
>>>> It is not clear to me how to specify the mt312 tuner, and 'modprobe
>>>> saa7134-dvb' fails with 'saa7130[0]: frontend initialization failed' 
>>>> when loading the wrong (mt532) frontend dependency.
>>>>         
>>> I get very similar behaviour from a Compro VideoMate DVB-T200, also
>>> using SAA713x bridge - dmesg reports "saa7130[0]/dvb: frontend
>>> initialization failed" when loading saa7134-dvb
>>>
>>> Any pointers gratefully received.
>>>
>>> BTW - previously tried in OpenSuSE 10.2, kernel 2.6.18.8 - currently in
>>> 10.3 beta 2, kernel 2.6.22.3
>>>
>>> Cheers,
>>>       
>> _______________________________________________
>> linux-dvb mailing list
>> linux-dvb at linuxtv.org
>> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>>
>>
>>     
>
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>
>   




More information about the linux-dvb mailing list