[linux-dvb] New Card: Compro VideoMate S300/S350 DVB-S

Richard (MQ) osl at 16hd.freeserve.co.uk
Mon Sep 3 21:29:02 CEST 2007


Thanks Jan,

I hadn't spotted that, but it makes no difference - even when I add
"options saa7134 card=72" I get:

> saa7130[0]: found at 0000:00:0c.0, rev: 1, irq: 19, latency: 32, mmio: 0xe2000000
> saa7130[0]: subsystem: 185b:c901, board: RTD Embedded Technologies VFG7350 [card=72,insmod option]
> saa7130[0]: board init: gpio is 853f43
> saa7130[0]: i2c eeprom 00: 5b 18 01 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7130[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
> saa7130[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 88 ff ff ff ff
> saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7130[0]: i2c eeprom 40: ff d5 00 c4 86 1e ff ff ff ff ff ff ff ff ff ff
> saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
> saa7130[0]: i2c eeprom 60: 30 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7130[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7130[0]: registered device video0 [v4l2]
> saa7130[0]: registered device vbi0
> saa7130[0]: registered device video1 [mpeg]

- but no /dev/dvb or anything below it.

relevant modules seem to be saa7134, saa7134-dvb, saa7134-empress and
mt352. Anything missing?

Any more ideas please? Anyone?!
-- 
Cheers
Richard (MQ)

Jan D. Louw wrote:
> Hi Richard,
> 
> Looks like your card is forced to the wrong card number. The T200 is 
> supposed to be auto detected as card #71, but yours was forced to #72 
> (insmod option). Check your /etc/modprobe.conf or similar file for 
> something like a 'option saa7134 card=72' statement.
> 
> Regards
> JD
> 
> Richard (MQ) wrote:
>> Jan,
>>
>> This is what dmesg has to say about the card on boot:
>>
>>> shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
>>> saa7130/34: v4l2 driver version 0.2.14 loaded
>>> ACPI: PCI Interrupt 0000:00:0c.0[A] -> GSI 16 (level, low) -> IRQ 19
>>> saa7130[0]: found at 0000:00:0c.0, rev: 1, irq: 19, latency: 32, mmio: 0xe2000000
>>> saa7130[0]: subsystem: 185b:c901, board: RTD Embedded Technologies VFG7350 [card=72,insmod option]
>>> saa7130[0]: board init: gpio is 843f00
>>> saa7130[0]: i2c eeprom 00: 5b 18 01 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
>>> saa7130[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
>>> saa7130[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 88 ff ff ff ff
>>> saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
>>> saa7130[0]: i2c eeprom 40: ff d5 00 c4 86 1e ff ff ff ff ff ff ff ff ff ff
>>> saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
>>> saa7130[0]: i2c eeprom 60: 30 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
>>> saa7130[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
>>> tuner 1-0062: chip found @ 0xc4 (saa7130[0])
>>> tuner 1-0062: type set to 1 (Philips PAL_I (FI1246 and compatibles))
>>> tuner 1-0062: type set to 1 (Philips PAL_I (FI1246 and compatibles))
>>> tuner 1-0063: chip found @ 0xc6 (saa7130[0])
>>> tuner 1-0068: chip found @ 0xd0 (saa7130[0])
>>> saa7130[0]: registered device video0 [v4l2]
>>> saa7130[0]: registered device vbi0
>>> ACPI: PCI Interrupt Link [ALKC] BIOS reported IRQ 0, using IRQ 22
>>> ACPI: PCI Interrupt Link [ALKC] enabled at IRQ 22
>>> ACPI: PCI Interrupt 0000:00:11.5[C] -> Link [ALKC] -> GSI 22 (level, low) -> IRQ 20
>>> PCI: Setting latency timer of device 0000:00:11.5 to 64
>>> saa7130[0]: registered device video1 [mpeg]
>> and lsmod (edited):
>>
>>> saa7134_empress        25860  0
>>> snd_via82xx            43800  0
>>> saa6752hs              26508  0
>>> tuner                  73640  0
>>> snd_ac97_codec        109220  1 snd_via82xx
>>> ac97_bus               18560  1 snd_ac97_codec
>>> snd_pcm                94212  3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
>>> snd_timer              38788  2 snd_seq,snd_pcm
>>> snd_page_alloc         26248  2 snd_via82xx,snd_pcm
>>> saa7134               137164  1 saa7134_empress
>>> shpchp                 47380  0
>>> pci_hotplug            45504  1 shpchp
>>> snd_mpu401             25100  0
>>> snd_mpu401_uart        24704  2 snd_via82xx,snd_mpu401
>>> snd_rawmidi            40320  2 snd_seq_midi,snd_mpu401_uart
>>> video_buf              39940  2 saa7134_empress,saa7134
>>> snd_seq_device         24460  3 snd_seq_midi,snd_seq,snd_rawmidi
>>> compat_ioctl32         17664  1 saa7134
>>> ir_kbd_i2c             24976  1 saa7134
>>> ir_common              50436  2 saa7134,ir_kbd_i2c
>>> videodev               42752  2 saa7134_empress,saa7134
>>> v4l2_common            32896  4 saa7134_empress,tuner,saa7134,videodev
>>> v4l1_compat            28676  2 saa7134,videodev
>>> i2c_core               39808  5 saa6752hs,tuner,saa7134,ir_kbd_i2c,i2c_viapro
>> I have an MT352 on the board - it's clearly marked - but no sign of a
>> module for it? Unless saa6752hs is something to do with it?
>>
>> As you say, we both need someone more knowledgeable to comment on this...
>>
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 
> 




More information about the linux-dvb mailing list