[linux-dvb] Hauppaug Nova T 500

Dave linuxdvblist at peskyweb.co.uk
Tue Sep 4 21:39:05 CEST 2007


Hi,

I have a Win TV Nova T 500 (NOT the diversity model). I can't tune any 
channels.

I have obtained the latest source from the mercurial repository as of 
2nd September, compiled and installed the drivers, provided the firmware 
file, and set the force_lna_activation module parameter.

  144  apt-get install linux-headers-$(uname -r) build-essential mercurial
  145  hg clone http://linuxtv.org/hg/v4l-dvb
  146  cd v4l-dvb
  149  make
  150  gedit /etc/modprobe.d/options

I added the line  ...

  options dvb-usb-dib0700 force_lna_activation=1

to  /etc/modprobe.d/options  ...


  151  make install
  159  cd /lib/firmware/2.6.20-16-generic/
  164  wget 
http://www.wi-bw.tfh-wildau.de/~pboettch/home/linux-dvb-firmware/dvb-usb-dib0700-03-pre1.fw
  167  shutdown -r now



Following a power cycle, dmesg seems to show sensible output regarding 
the card and the firmware has been loaded ...

[   15.726264] dib0700: loaded with support for 5 different device-types
[   15.815691] dvb-usb: found a 'Hauppauge Nova-T 500 Dual DVB-T' in 
cold state, will try to load a firmware
[   15.872816] dvb-usb: downloading firmware from file 
'dvb-usb-dib0700-03-pre1.fw'
[   15.923822] ACPI: PCI Interrupt 0000:00:1e.2[A] -> GSI 23 (level, 
low) -> IRQ 20
[   15.923848] PCI: Setting latency timer of device 0000:00:1e.2 to 64
[   16.071836] dib0700: firmware started successfully.
[   16.251026] intel8x0_measure_ac97_clock: measured 59591 usecs
[   16.251030] intel8x0: clocking to 48000
[   16.578865] dvb-usb: found a 'Hauppauge Nova-T 500 Dual DVB-T' in 
warm state.
[   16.578935] dvb-usb: will pass the complete MPEG2 transport stream to 
the software demuxer.
[   16.579118] DVB: registering new adapter (Hauppauge Nova-T 500 Dual 
DVB-T)
[   16.707221] DVB: registering frontend 0 (DiBcom 3000MC/P)...
[   16.744206] MT2060: successfully identified (IF1 = 1220)
[   17.297369] dvb-usb: will pass the complete MPEG2 transport stream to 
the software demuxer.
[   17.297586] DVB: registering new adapter (Hauppauge Nova-T 500 Dual 
DVB-T)
[   17.303410] DVB: registering frontend 1 (DiBcom 3000MC/P)...
[   17.308000] MT2060: successfully identified (IF1 = 1220)
[   17.923372] input: IR-receiver inside an USB DVB receiver as 
/class/input/input4
[   17.923512] dvb-usb: schedule remote query interval to 150 msecs.
[   17.923517] dvb-usb: Hauppauge Nova-T 500 Dual DVB-T successfully 
initialized and connected.
[   17.923640] usbcore: registered new interface driver dvb_usb_dib0700

...



And I believe this shows the lnb option was recognised? ...

root at black:/home/dave# cat 
/sys/module/dvb_usb_dib0700/parameters/force_lna_activation
1

...


Using scan from the dvb-utils package, just shows "tuning failed" for 
each frequency for uk-Craigkelly, which I am pretty sure is the right 
tuning file for me ...

root at black:/home/dave# scan 
/usr/share/doc/dvb-utils/examples/scan/dvb-t/uk-Craigkelly
scanning /usr/share/doc/dvb-utils/examples/scan/dvb-t/uk-Craigkelly
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 490000000 0 2 9 3 0 3 0
initial transponder 514000000 0 2 9 1 0 3 0
initial transponder 538000000 0 2 9 3 0 3 0
initial transponder 570000000 0 2 9 1 0 3 0
initial transponder 618000000 0 2 9 1 0 3 0
initial transponder 642000000 0 2 9 1 0 3 0
 >>> tune to: 
490000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
 >>> tune to: 
490000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE 
(tuning failed)
WARNING: >>> tuning failed!!!
 >>> tune to: 
514000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
 >>> tune to: 
514000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE 
(tuning failed)
WARNING: >>> tuning failed!!!
 >>> tune to: 
538000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
 >>> tune to: 
538000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE 
(tuning failed)
WARNING: >>> tuning failed!!!
 >>> tune to: 
570000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
 >>> tune to: 
570000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE 
(tuning failed)
WARNING: >>> tuning failed!!!
 >>> tune to: 
618000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
 >>> tune to: 
618000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE 
(tuning failed)
WARNING: >>> tuning failed!!!
 >>> tune to: 
642000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
 >>> tune to: 
642000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_4:HIERARCHY_NONE 
(tuning failed)
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)
Done.



Adding the verbose option to scan outputs the following line many times 
for each frequency ...
 >>> tuning status == 0x01


The card works under Windows XP with the same aerial / cable 
configuration. Does anyone know what's wrong, or are there any further 
diagnostics I can run to try and determine the problem? I am quite happy 
to put some effort into this, but I need pointed in the right direction.


Many thanks,
Dave





More information about the linux-dvb mailing list