[linux-dvb] New Card: Compro VideoMate S220 DVB-T

hermann pitton hermann-pitton at arcor.de
Thu Sep 6 00:40:44 CEST 2007


Hi Richard,

Am Mittwoch, den 05.09.2007, 19:11 +0100 schrieb Richard (MQ):
> Richard (MQ) wrote:
> > Hi List,
> > 
> > The Compro VideoMate T200,T200a and T300 are listed at
> > http://linuxtv.org/hg/v4l-dvb/file/18f323a05fbe/linux/Documentation/video4linux/CARDLIST.saa7134
> > - but no T220
> > 
> > It's a DVB-T card based on SAA7130 and MT352, incorrectly identified in
> > OpenSuSE 10.3 (Beta 2) as "Compro Videomate DVB-T200 [185b:c901]" (which
> > confused me immensely, because that was what I thought I'd bought, but
> > was wrong!). Needless to say, config as a T200 doesn't work.
> > 
> > Is there any chance of support for this card please? Can I do anything
> > to help?
> > 
> > PS - This is a new thread spun off from "New Card: Compro VideoMate
> > S300/S350 DVB-S" as I'd rather hijacked it...
> 
> The following transferred from S300/S350 thread as mentioned above:
> 
> > > Am Dienstag, den 04.09.2007, 09:19 +0200 schrieb Jan Louw:
> >>> >> > If it's a T220 I think you're out of luck. Check out
> >>> >> >
> http://linuxtv.org/hg/v4l-dvb/file/18f323a05fbe/linux/Documentation/video4linux/CARDLIST.saa7134
> 
> >>> >> > for a list of cards (should be somewhere under
> >>> >> > /usr/src/linux/Documentation as well). The Compro VideoMate
> T200,T200a
> >>> >> > and T300 is listed, but no T220. I did see some T220 posts a
> while back.
> >>> >> > Maybe they will be of some use to you.
> >>> >> >
> >>> >> > What is strange is that your card is not detected as UNKNOWN.
> Maybe it's
> >>> >> > because the vendor:product of 185b:c901 is the same as the
> T200's or
> >>> >> > maybe YaST added an 'options saa7134 card=72' somewhere...
> > >
> > > If again a card with same PCI subsystem ID appears, like now, it should
> > > fall through the eeprom detection Hartmut has added and print a warning
> > > about "unknow tuner stuff". You can override it then with the
> > > card=number insmod option.
> 
> Without card=n insmod option, the card is wrongly autodetected as
> DVB-T200 (hence my confusion in the earlier thread), and as you suggest
> an "Unexpected tuner type" message comes up - this with "options saa7134
> i2c_scan=1" in /etc/modprobe.conf.local
> 
> 
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130/34: v4l2 driver version
> 0.2.14 loaded
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: found at 0000:00:0c.0,
> rev: 1, irq: 18, latency: 32, mmio: 0xe2000000
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: subsystem: 185b:c901,
> board: Compro Videomate DVB-T200 [card=71,autodetected]
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: board init: gpio is 843f00
> Sep  5 19:13:36 103-Beta2-2 kernel: input: saa7134 IR (Compro Videomate
> DV as /class/input/input9
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 00: 5b 18 01
> c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 10: 00 ff 86
> 0f ff 20 ff ff ff ff ff ff ff ff ff ff
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 20: 01 40 01
> 03 03 ff 03 01 08 ff 00 88 ff ff ff ff
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 30: ff ff ff
> ff ff ff ff ff ff ff ff ff ff ff ff ff
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 40: ff d5 00
> c4 86 1e ff ff ff ff ff ff ff ff ff ff
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 50: ff ff ff
> ff ff ff ff ff ff ff ff ff ff ff ff cb
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 60: 30 ff ff
> ff ff ff ff ff ff ff ff ff ff ff ff ff
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c eeprom 70: ff ff ff
> ff ff ff ff ff ff ff ff ff ff ff ff ff
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c scan: found device @
> 0x1e  [???]
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c scan: found device @
> 0xa0  [eeprom]
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c scan: found device @
> 0xc4  [???]
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: i2c scan: found device @
> 0xd0  [???]
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: Unexpected tuner type
> info: d5 in eeprom
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: registered device video0
> [v4l2]
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]: registered device vbi0
> Sep  5 19:13:36 103-Beta2-2 kernel: saa7130[0]/dvb: frontend
> initialization failed
> 
> "modprobe mt352" does nothing AFAICT, even when "debug=1" is added
> > I can readily try the mercurial source build if that might help, I'm
> > currently using kernel 2.6.22.3 (OpenSuSE 10.3 beta 2)
> >
> > Where do I find the list of "saa7134 card=x" - is it in that source
> > code somewhere?
> > >
> > Latest always in mercurial saa7134.h and Documentation/saa7134.CARDLIST,
> > > but won't help. Best approach so far was by Murray Graham I guess.
> > > http://www.linuxtv.org/pipermail/linux-dvb/2007-July/019030.html
> > >
> > > At least a read of the qt1010 register 0x29 returned 0x39, if this is
> > > safe for the tuner ID. Think 0xd5 for the tuner ID in the eeprom is not
> > > yet sure, might be vendor specific. On the T100 is one, dmesg, eeprom
> > > dump and i2c_scan not yet available.
> > >
> > > Tuner is at 0x62 (7bit notation) and mt352 at 0xf (0x1e >> 1).
> > > Something claims to be an analog demod at 0x86 (8bit), but hard to
> > > believe.
> 
> I have emailed Murray Graham directly (address from that archive) but no
> response as yet.
> 
> Thanks for your help so far, I have grabbed the mercurial source and am
> now trying to digest it...
> 

thanks for your report so far!

I suggest to wait for Murray and his code. He introduced already the
qt1010 to saa7134-dvb.c and started to work on the mt352. Better old
datasheets for it should still be around.

Output from the T100 with the visible qt1010 might help too. The
i2c_scan confirms the eeprom assumptions, except that an mpeg encoder
and an analog demod did not show up yet.

Cheers,
Hermann







More information about the linux-dvb mailing list