[linux-dvb] DVB API update

Manu Abraham abraham.manu at gmail.com
Tue Sep 18 17:18:04 CEST 2007


Felix Domke wrote:

> BTW, this doesn't hold my "backward compatibility" request - if an
> application wants to tune a dvb-s transponder with the new api
> (DVBFE_SET_PARAMS), it won't run against an old api (which only
> implements FE_SET_FRONTEND, but could technically tune). But it seems
> that nobody else cares about this.
> 

I have put up the hacked version of the old szap, which works with both
the old and new API's
This just checks for the API version, which ioctl's to be used.

http://abraham.manu.googlepages.com/szap.c


Manu



More information about the linux-dvb mailing list