[linux-dvb] dib0700 new i2c implementation

Nicolas Will nico at youplala.net
Wed Aug 27 10:25:28 CEST 2008


On Wed, 2008-08-27 at 09:10 +0200, Eduard Huguet wrote:
> 
>         ---------- Missatge reenviat ----------
>         From: "Devin Heitmueller" <devin.heitmueller at gmail.com>
>         To: linux-dvb <linux-dvb at linuxtv.org>
>         Date: Tue, 26 Aug 2008 21:15:20 -0400
>         Subject: [linux-dvb] dib0700 new i2c implementation
>         The attached patch implements the new dib0700 i2c API, which
>         requires
>         v1.20 of the firmware.  It addresses some classes of i2c
>         problems (in
>         particular the one I had where i2c reads were being sent onto
>         the bus
>         as i2c write calls)
>         
>         I would appreciate it if those with dib0700 based devices
>         would try
>         out the patch and provide feedback as to whether they have any
>         problems.  I've done testing with the Pinnacle PCTV HD Pro USB
>         801e
>         stick, but I don't have any other dib0700 based devices.
>         
>         Thanks to Patrick Boettcher for providing the firmware, sample
>         code,
>         and peer review of the first version of this patch.
> 
> Hi, 
>     Thanks for your work, first of all. ¿Do you think this patch might
> solve the problems that seem to be appeared since the new firmware is
> out with the Hauppauge Nova-T 500, like random reboots, etc... (what's
> ths state on this, anyway?) ?

Sorry I for my going AWOL...

I've spending most of my time out of my country of residence for a
project these last 6 months.

Testing is a bit difficult for me. My WAF goes down when I spent part of
the week end on the TV computer testing stuff instead of spending
quality time with the family.  Also, I do not want to leave the only TV
system in the house in an unstable state right before leaving for a
trip.

However, it seems that my problems with the 1.20 firmware were most
probably due to leftover 1.10 files scattered
around /lib/firmware/linux*.

I may be wrong and I did not spend much time on this, as I reverted to
1.10 before boarding yet another plane.

I may have experienced a remote control issue too.

But again, I did not take the time to properly sit in front of the
system and test things with a clear mind and some proper process.

Sorry.

Maybe this week-end.

> 
> I delayed the adoption of the new 1.20 firmware because of those
> problems, because I didn't want to leave the machine in a complete
> unusable state...

I hear you.

Nico




More information about the linux-dvb mailing list