[linux-dvb] tm6010 - Compiles All Drivers, but not tm6010 Strange!

Mauro Carvalho Chehab mchehab at infradead.org
Thu Dec 4 17:27:21 CET 2008


On Thu, 4 Dec 2008 08:08:55 +0530
"leo theGreat" <leo.thealmighty at gmail.com> wrote:

> Hi Everbody,
> 
> I tried to compile the drivers from
> 'http://linuxtv.org/hg/~mchehab/tm6010/<http://linuxtv.org/hg/%7Emchehab/tm6010/>
> '.
> 
> I tried 4 days ago archive..... 5 weeks old and 7 months old... all the same
> results.
> 
> All drivers compile fine... but not tm6000. Compilation runs fine. It
> produces around 200+ drivers but not any tm6000 driver. Although tm6000
> folder is present in all of these archives. But it remains as source file
> only ( like .c, .h etc ) and doesnt get compiled into the driver like other
> drivers. As the compilation goes fine without any errors. I am wondering If
> I am doing something wrong or is there a different way to do it.
> 
> I use 'make' or sometimes 'make all' and then 'make install'.
> 
> According to Mark Breddemann's ( on this Mailing List ) post he has
> successfully compiled these drivers. Kindly guide me the way also. I know
> these drivers are still in the development. But analog support is working.
> And i need only that. My Chipset is Trident TV Master  5600 AI.
> Kindly help me out! Hope to get a reply soon. :)

You need to do "make menuconfig" and select tm6000. 

I'm currently working on the driver and I'll probably merge soon a version with
analog support working fine, including the tm6000-alsa module. The current
version has no sound, and have a serious issue on analog handling, causing
kernel hangs.

Cheers,
Mauro



More information about the linux-dvb mailing list