[linux-dvb] twinhan 1020A not working

Remy Bohmer linux at bohmer.net
Sun Jan 6 13:56:14 CET 2008


Hello Gregor,

Can you please give me the revision numbers?
These are listed somewhere on the boards.
As mentioned before, different revisions are different clones from
other boards en need a different driver configuration.
Besides, I do not know if all combinations of different revisions of
the boards work with 1 driver and generic setting. Maybe with the
latest changes CityK was talking about, it is possible now?

At first, I would suggest to leave the 'green' board out, and just put
in the cards of the same revision and get that working, when this
works you can put back in your 'green' card, and try get that working
also.

To check which firmware version you have, you can enable the logging
inside the drivers.

It is good to hear that you do not have a yellow card (rev3) in the
system, which seems to be the most unstable card of the series.

Luckily you do not need a CAM on these boards, because that part is
very unstable inside the cards itself, which sometimes require a full
power off of the system (power cable removed for at least 20 seconds),
to get the boards reset again and to get them working properly... (in
fact, if the CAM part of some board is getting into an undefined
state, this will also result in a unbootable system, because the
firmware is not behaving properly anymore...)

Note: To work around this reset issue partly, it might be worth trying
to add these flags to your modprobe.conf: 'options dst dst_addons=32'
I added this dst_addons option set to 32(=DST_TYPE_HAS_CA) to make
sure the card is reset on load time of the dst-driver. if omitted, the
dst driver will not be able to communicate to the card during
dst_probe() on a cold boot and loading the dst (and dst_ca) driver
fails. (A soft reboot will load the driver after reboot without
problems.)


Kind Regards,

Remy


2008/1/5, Gregor Fuis <gujs.lists at gmail.com>:
> CityK wrote:
> > Just some random thoughts:
> > - do you have any other dvb cards installed in this system (PCI/USB/or
> > otherwise)?
> > - are you using CAMs with all 4 of these cards ?
> >
> > (I'm already thinking that this is going to be somehow related to CAM
> > use .... no real basis for that thought, just an intuition)
> >
> Hi,
>
> I don't use any other dvb card in that computer, but maybe one of them
> is other revision, because 3 of them are blue and one green.
>
> I don't need CAM so if you have a solution without CAM that should work
> just tell me about it.
>
> Would it make any difference if I try with latest v4l-dvb or any other
> hg repository?
>
> Regards,
>
> Gregor
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>



More information about the linux-dvb mailing list