[linux-dvb] Problem with Twinhan 102g not being recognized

Corey Ashford yeroca at yahoo.com
Sun Jan 27 08:14:11 CET 2008


Hello,

A little background first...

I've recently switched over from using MyTheater on Windows to MythTV
under Fedora 8.  I'm running the latest Fedora 8 kernel, 2.6.14-107. 
Under Windows XP, I was able to use my Twinhan 102g card with the FTA
satellite antenna I have.  However, under linux, it appears the card is
not recognized properly.  I actually have two bt878-based cards in my
system.. a Twinhan 3250 ATSC card which is recognized and is working
properly, and a Twinhan 102g which is not recognized completely.

If I rmmod bttv, bt878, dvb_bt8xx, dst, and then /sbin/modprobe bttv, I
get this:

[corey at Family_Room log]# dmesg -c
bttv: driver version 0.9.17 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:02:0a.0, irq: 21, latency: 64, mmio:
0xbfefe000
bttv0: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID is
1822:000
1
bttv0: using: Twinhan DST + clones [card=113,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00f36cff [init]
bttv0: tuner absent
bttv0: add subdevice "dvb0"
bttv: Bt8xx card found (1).
bttv1: Bt878 (rev 17) at 0000:02:0b.0, irq: 16, latency: 64, mmio:
0xbfefc000
bttv1: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID is
1822:000
1
bttv1: using: Twinhan DST + clones [card=113,autodetected]
bttv1: gpio: en=00000000, out=00000000 in=00f5ffff [init]
bttv1: tuner absent
bttv1: add subdevice "dvb1"
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:02:0a.1[A] -> GSI 22 (level, low) -> IRQ 21
bt878_probe: card id=[0x11822],[ Twinhan VisionPlus DVB ] has DVB
functions.
bt878(0): Bt878 (rev 17) at 02:0a.1, irq: 21, latency: 64, memory:
0xbfeff000
bt878: Bt878 AUDIO function found (1).
ACPI: PCI Interrupt 0000:02:0b.1[A] -> GSI 23 (level, low) -> IRQ 16
bt878_probe: card id=[0x11822],[ Twinhan VisionPlus DVB ] has DVB
functions.
bt878(1): Bt878 (rev 17) at 02:0b.1, irq: 16, latency: 64, memory:
0xbfefd000
DVB: registering new adapter (bttv0)
dst(0) dst_get_device_id: Recognise [ATSCAD]
DST type flags : 0x10 firmware version = 2
dst(0) dst_get_mac: MAC Address=[00:08:ca:16:cb:00]
dst(0) dst_get_tuner_info: DST TYpe = MULTI FE
dst(0) dst_get_tuner_info: DST type has TS=188
dst(0) dst_fw_ver: Firmware Ver = 1.3 Build = 06, on 9:45, 1-3-2005
dst(0) dst_card_type: Device Model=[VP32500]
dst(0) dst_get_vendor: Vendor=[TWINHAN]
DVB: registering frontend 0 (DST ATSC)...
DVB: registering new adapter (bttv1)
dst(1) dst_get_device_id: Recognise [DST-03T]
dst(1) dst_get_device_id: Unsupported
dst(1) dst_get_device_id: Unsupported
dst(1) dst_get_device_id: [DST-03T] has a [MB 86A15]
dst(1) dst_get_device_id: [DST-03T] has a [MB 86A15]
DST type flags : 0x2 ts204 0x4 symdiv 0x10 firmware version = 2
dst(1) dst_get_mac: MAC Address=[00:08:ca:16:bc:00]
DVB: registering frontend 1 (DST DVB-S)...

Besides the "Unsupported" error, my evidence that the card is not
working is that I cannot get any channels out of a scan.  I know I have
the right frequency, symbol rate, and polarity, etc.  The card is sort
of working, in that diseqc commands are making it to the rotor, but I
think the tuner is not recognized, so tuning in a stream simply does
not work.

I tried doing the modprobe of the modules one at a time, but it appears
that bttv is bringing in the other three modules automatically, and I
don't know how to add the "verbose" parameter when it does that.

I've also tried
/sbin/modprobe bttv card=113 card=113
but the driver seemed to ignore those options.

Any suggestions would be appreciated.

Thanks for your consideration,

- Corey


      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs



More information about the linux-dvb mailing list