[linux-dvb] Patch for analog part for Avermedia A700 fails to apply

Eduard Huguet eduardhc at gmail.com
Tue Jan 29 11:07:16 CET 2008


Hi,
    I'm just trying to apply the first patch mentioned on the wiki for this
cardad I'm getting the following result:

From
http://www.linuxtv.org/wiki/index.php/AVerMedia_AVerTV_DVB-S_Pro_%28A700%29<http://www.linuxtv.org/wiki/index.php/AVerMedia_AVerTV_DVB-S_Pro_%2528A700%2529>
:

# patch -p1 < ../1_avertv_A700_analog_part.diff

patching file linux/drivers/media/video/saa7134/saa7134-cards.c
Hunk #1 succeeded at 3992 with fuzz 2 (offset 41 lines).
Hunk #2 succeeded at 4243 (offset 41 lines).
Hunk #3 succeeded at 5233 (offset 59 lines).
patching file linux/drivers/media/video/saa7134/saa7134.h
Hunk #1 FAILED at 260.
1 out of 1 hunk FAILED -- saving rejects to file
linux/drivers/media/video/saa7134/saa7134.h.rej
patching file linux/Documentation/video4linux/CARDLIST.saa7134
Hunk #1 FAILED at 129.
1 out of 1 hunk FAILED -- saving rejects to file
linux/Documentation/video4linux/CARDLIST.saa7134.rej


linux/drivers/media/video/saa7134/saa7134.h.rej:

***************
*** 260,265 ****
  #define SAA7134_BOARD_BEHOLD_COLUMBUS_TVFM 128
  #define SAA7134_BOARD_BEHOLD_607_9FM  129
  #define SAA7134_BOARD_BEHOLD_M6               130

  #define SAA7134_MAXBOARDS 8
  #define SAA7134_INPUT_MAX 8
--- 260,266 ----
  #define SAA7134_BOARD_BEHOLD_COLUMBUS_TVFM 128
  #define SAA7134_BOARD_BEHOLD_607_9FM  129
  #define SAA7134_BOARD_BEHOLD_M6               130
+ #define SAA7134_BOARD_AVERMEDIA_A700  131

  #define SAA7134_MAXBOARDS 8
  #define SAA7134_INPUT_MAX 8


This is with a clean copy of the repository. Apparently in the HG
saa7134.hfile the value 131 is assigned to a Twinhan card:

saa7134.h:260 #define SAA7134_BOARD_TWINHAN_DTV_DVB_3056 131


Anyway, I've added the #define for the A700 card (so I have now 2 cards
using the same ID...), and the dmesg output I'm getting is the following:

[   27.988329] saa7130/34: v4l2 driver version 0.2.14 loaded
[   27.999541] ACPI: PCI Interrupt 0000:01:09.0[A] -> Link [APC1] -> GSI 16
(level, low)       -> IRQ 16
[   27.999550] saa7133[0]: found at 0000:01:09.0, rev: 209, irq: 16,
latency: 32, mmio: 0      xfddfe000
[   27.999556] saa7133[0]: subsystem: 1461:a7a1, board: UNKNOWN/GENERIC
[card=0,autodetec      ted]
[   27.999566] saa7133[0]: board init: gpio is 2f600
[   28.125847] nvidia: module license 'NVIDIA' taints kernel.
[   28.263205] ACPI: Fan [FAN] (on)
[   28.524850] saa7133[0]: i2c eeprom 00: 61 14 a1 a7 ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524856] saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524860] saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524864] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524868] saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524872] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524876] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524880] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524883] saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524887] saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524891] saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524895] saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524899] saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524903] saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.524907] saa7133[0]: i2c eeprom e0: 00 01 81 af ea b5 ff ff ff ff ff
ff ff ff ff ff
[   28.524911] saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff
[   28.551625] saa7133[0]: registered device video0 [v4l2]
[   28.551640] saa7133[0]: registered device vbi0


Unfortunately I can't test if it works or not, as I don't have any device to
attach to the analog input.

Best regards,
  Eduard Huguet
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080129/af89eb99/attachment.htm 


More information about the linux-dvb mailing list