[linux-dvb] Avermedia M115 MiniPCI hybrid

luc legrand legrandluc at gmail.com
Fri May 2 20:51:19 CEST 2008


last time I tried with v4l-dvb-experimental from mcentral.de in order
to compile I did :
make LINUXINCLUDE="-I`pwd`/linux/include -I`pwd`/v4l -Iinclude
-include include/linux/autoconf.h"

and here is what dmesg tells me :

# dmesg | grep saa
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:09:04.0, rev: 209, irq: 16, latency: 0,
mmio: 0xd2005000
saa7133[0]: subsystem: 1461:a836, board: Avermedia M115 [card=119,autodetected]
saa7133[0]: board init: gpio is a400000
saa7133[0]: i2c eeprom 00: 61 14 36 a8 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 10: ff ff ff ff ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08 ff 00 c0 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 1-0061: chip found @ 0xc2 (saa7133[0])
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7134_dvb: Unknown symbol videobuf_dvb_unregister
saa7134_dvb: Unknown symbol videobuf_dvb_register

# dmesg | grep dvb
/home/ouam/.TunerTV/v4l-dvb-experimental/v4l/tuner-core.c: setting
tuner callback
/home/ouam/.TunerTV/v4l-dvb-experimental/v4l/tuner-core.c: setting
tuner callback
/home/ouam/.TunerTV/v4l-dvb-experimental/v4l/xc3028-tuner.c: attach request!
/home/ouam/.TunerTV/v4l-dvb-experimental/v4l/tuner-core.c: xc3028
tuner successfully loaded
videobuf_dvb: disagrees about version of symbol dvb_dmxdev_init
videobuf_dvb: Unknown symbol dvb_dmxdev_init
videobuf_dvb: disagrees about version of symbol videobuf_read_stop
videobuf_dvb: Unknown symbol videobuf_read_stop
videobuf_dvb: disagrees about version of symbol videobuf_waiton
videobuf_dvb: Unknown symbol videobuf_waiton
videobuf_dvb: disagrees about version of symbol dvb_dmx_release
videobuf_dvb: Unknown symbol dvb_dmx_release
videobuf_dvb: disagrees about version of symbol videobuf_read_start
videobuf_dvb: Unknown symbol videobuf_read_start
videobuf_dvb: disagrees about version of symbol dvb_net_init
videobuf_dvb: Unknown symbol dvb_net_init
videobuf_dvb: disagrees about version of symbol dvb_dmx_swfilter
videobuf_dvb: Unknown symbol dvb_dmx_swfilter
videobuf_dvb: disagrees about version of symbol dvb_dmxdev_release
videobuf_dvb: Unknown symbol dvb_dmxdev_release
videobuf_dvb: disagrees about version of symbol dvb_frontend_detach
videobuf_dvb: Unknown symbol dvb_frontend_detach
videobuf_dvb: disagrees about version of symbol dvb_net_release
videobuf_dvb: Unknown symbol dvb_net_release
videobuf_dvb: disagrees about version of symbol dvb_unregister_frontend
videobuf_dvb: Unknown symbol dvb_unregister_frontend
videobuf_dvb: disagrees about version of symbol dvb_register_frontend
videobuf_dvb: Unknown symbol dvb_register_frontend
videobuf_dvb: disagrees about version of symbol dvb_dmx_init
videobuf_dvb: Unknown symbol dvb_dmx_init
videobuf_dvb: Unknown symbol videobuf_to_dma
saa7134_dvb: Unknown symbol videobuf_dvb_unregister
saa7134_dvb: Unknown symbol videobuf_dvb_register

Luc

2008/5/2 Markus Rechberger <mrechberger at gmail.com>:
> Hi,
>
>
>  On 5/2/08, luc legrand <legrandluc at gmail.com> wrote:
>
> > Thank you Markus for your answer.
>  > I have seen that patch but it seems that there is still a problem with
>  > this card.
>  > As you can see here I'm not the onlyone who encounter this problem
>  > with this card (second post from luca porcu) :
>  > http://fcp.surfsite.org/modules/newbb/viewtopic.php?viewmode=flat&order=ASC&topic_id=55288&forum=10&move=prev&topic_time=1208143235
>  >
>
>  what error do you actually get there?
>
>  -Markus
>



More information about the linux-dvb mailing list