[linux-dvb] random "no frontend was attached"

thomas schorpp thomas.schorpp at googlemail.com
Tue Jan 6 20:44:47 CET 2009


Tomasz Chmielewski schrieb:
> I have a DVB USB device which identifies as:
> 
> # lsusb
> Bus 001 Device 006: ID 04ca:f001 Lite-On Technology Corp.
> 
> 
> Randomly, upon machine bootup, it is not detected properly ("no frontend was attached"):
> 
> usb 1-6: new high speed USB device using ehci_hcd and address 4                                                              
> usb 1-6: configuration #1 chosen from 1 choice                                                                               
> dvb-usb: found a 'LITE-ON USB2.0 DVB-T Tuner' in warm state.                                                                 
> dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.                                              
> DVB: registering new adapter (LITE-ON USB2.0 DVB-T Tuner)                                                                    
> dvb-usb: no frontend was attached by 'LITE-ON USB2.0 DVB-T Tuner'                                                            
> input: IR-receiver inside an USB DVB receiver as /class/input/input6                                                         
> dvb-usb: schedule remote query interval to 150 msecs.                                                                        
> dvb-usb: LITE-ON USB2.0 DVB-T Tuner successfully initialized and connected.
> 
> 
> As a result, using DVB is impossible until I plug the device out 
> and plug it in again.

Does not work here.

> 
> This is the only solution to bring it back to life - if I remove
> DVB modules and insert them again, I get:
> 
> dvb-usb: bulk message failed: -22 (1/2)                                                                                      
> dvb-usb: bulk message failed: -22 (1/-150651080)                                                                             
> dvb-usb: bulk message failed: -22 (1/662)                                                                                    
> dvb-usb: bulk message failed: -22 (1/1024)                                                                                   
> dvb-usb: bulk message failed: -22 (1/2)          
> 
> 
> Are there any "better" solutions to that, other then re-inserting the USB device?
> If not, what could be the cause of it?
> 
> I use Linux kernel 2.6.28.
> 
> 

http://www.linuxtv.org/pipermail/linux-dvb/2009-January/031165.html



More information about the linux-dvb mailing list