[linux-dvb] em28xx device problem (idVendor=1578, idProduct=800c)

zhu yu zhuyu87 at gmail.com
Sun Aug 15 10:44:44 CEST 2010


HI,
I have a em28xx based device (Huaqi DLCW-130), after modify em28xx-card.c to
add the device 1578:800c, it's succeed to find "video0" file at /dev/ . and
succeed to capture picture with "cheese" webcam software,  it works well in
320*256, but when the resolution sets to 512*408, there are some green
stripes on the picture, and it gets to be worse when set higher.

for example
512 * 408    2010-08-15-164347.jpg

[80340.339028] usb 1-8: new high speed USB device using ehci_hcd and address
11
[80340.458032] usb 1-8: New USB device found, idVendor=1578, idProduct=800c

[80340.458044] usb 1-8: New USB device strings: Mfr=0, Product=1,
SerialNumber=0
[80340.458054] usb 1-8: Product: HuaQi Digital Lab DL-800C

[80340.458181] usb 1-8: configuration #1 chosen from 1 choice

[80340.458345] em28xx: New device HuaQi Digital Lab DL-800C @ 480 Mbps
(1578:800c, interface 0, class 0)

[80340.458457] em28xx #0: chip ID is em2870

[80340.533907] em28xx #0: i2c eeprom 00: 1a eb 67 95 78 15 0c 80 00 00 11 00
6a 36 00 00
[80340.533937] em28xx #0: i2c eeprom 10: 00 00 04 57 82 00 00 00 00 00 00 00
00 00 00 00
[80340.533963] em28xx #0: i2c eeprom 20: 01 00 00 01 f0 10 00 00 00 00 00 00
5b 00 00 00
[80340.533987] em28xx #0: i2c eeprom 30: 00 00 20 40 20 80 02 20 01 01 00 00
00 00 00 00
[80340.534025] em28xx #0: i2c eeprom 40: 00 00 00 00 00 00 00 00 00 00 00 00
ff ff ff ff
[80340.534058] em28xx #0: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff
ff ff ff ff
[80340.534089] em28xx #0: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff 36 03
48 00 75 00
[80340.534122] em28xx #0: i2c eeprom 70: 61 00 51 00 69 00 20 00 44 00 69 00
67 00 69 00
[80340.534155] em28xx #0: i2c eeprom 80: 74 00 61 00 6c 00 20 00 4c 00 61 00
62 00 20 00
[80340.534185] em28xx #0: i2c eeprom 90: 44 00 4c 00 2d 00 38 00 30 00 30 00
43 00 00 00
[80340.534210] em28xx #0: i2c eeprom a0: 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00
[80340.534235] em28xx #0: i2c eeprom b0: 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00
[80340.534260] em28xx #0: i2c eeprom c0: 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00
[80340.534289] em28xx #0: i2c eeprom d0: 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00
[80340.534322] em28xx #0: i2c eeprom e0: 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00
[80340.534354] em28xx #0: i2c eeprom f0: 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00
[80340.534389] em28xx #0: EEPROM ID= 0x9567eb1a, EEPROM hash = 0xb938d5df
[80340.534398] em28xx #0: EEPROM info:
[80340.534404] em28xx #0:       No audio on board.
[80340.534410] em28xx #0:       500mA max power
[80340.534417] em28xx #0:       Table at 0x04, strings=0x366a, 0x0000,
0x0000
[80340.621015] em28xx #0: Sensor is mt9m001, using model
EM2710/EM2750/EM2751 webcam grabber entry.
[80340.621028] em28xx #0: Identified as EM2710/EM2750/EM2751 webcam grabber
(card=22)
[80340.621039] em28xx #0: v4l2 driver version 0.1.2
[80340.625721] em28xx #0: V4L2 video device registered as video0

Anyone have some idea?
Thank you!

Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.linuxtv.org/pipermail/linux-dvb/attachments/20100815/d8a6f34c/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 2010-08-15-164347.jpg
Type: image/jpeg
Size: 24752 bytes
Desc: not available
URL: <http://www.linuxtv.org/pipermail/linux-dvb/attachments/20100815/d8a6f34c/attachment.jpg>


More information about the linux-dvb mailing list